Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi configure error
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-09-16 07:44:57


The problem is highlighted in the configure output:

>> checking whether build environment is sane... configure: error: newly created file is older than distributed files!
>> Check your system clock

Don't use touch. Fix your system clock and re-untar the Open MPI tarball. Then configure will work fine.

On Sep 16, 2011, at 7:22 AM, 郝文平 wrote:

>
> Thank you for your reply.Before I configured OPENMPI,I used the commond "touch * ". It did work. But i think the mistake is that: "configure: error: Failed to build GNU libltdl. This usually means that something is incorrectly setup with your environment. There may be useful information in opal/libltdl/config.log. You can also disable GNU libltdl (which will disable
> dynamic shared object loading) by configuring with --disable-dlopen." Hope your comments.
> Thanks!
>
>
> At 2011-09-15 20:11:22,"Jeff Squyres (jsquyres)" <jsquyres_at_[hidden]> wrote:
> OMPI 1.2.6 is fairly ancient; you might want to upgrade.
>
> The problem is your systems clock. Set it properly and configure should be ok.
>
> Sent from my phone. No type good.
>
> On Sep 14, 2011, at 11:21 PM, 郝文平 <hwp22651304_at_[hidden]> wrote:
>
>> Hello,
>> When i try to compile openmpi-1.2.6.tar.bz2 on my computer with ifort Compilier.My system is Red Hat4.6 86x64.But some mistakes happen when the process of configuring.Mistakes as follows:
>> $./configure --prefix=~/haowp/opt/openmpi FC=ifort F90=ifort
>> .........
>> ......
>> *** GNU libltdl setup
>> configure: OMPI configuring in opal/libltdl
>> configure: running /bin/sh './configure' '--prefix=/stg/s1p1/users/yuanjm/haowp/opt/openmpi' 'FC=ifort' 'F90=ifort' --enable-ltdl-convenience --disable-ltdl-install --enable-shared --disable-static --cache-file=/dev/null --srcdir=.
>> checking for a BSD-compatible install... /usr/bin/install -c
>> checking whether build environment is sane... configure: error: newly created file is older than distributed files!
>> Check your system clock
>> configure: /bin/sh './configure' *failed* for opal/libltdl
>> configure: error: Failed to build GNU libltdl. This usually means that something
>> is incorrectly setup with your environment. There may be useful information in
>> opal/libltdl/config.log. You can also disable GNU libltdl (which will disable
>> dynamic shared object loading) by configuring with --disable-dlopen.
>>
>> $vi /opml/libltdl/config.log
>> ## ----------- ##
>> ## confdefs.h. ##
>> ## ----------- ##
>> #define PACKAGE_NAME "libltdl"
>> #define PACKAGE_TARNAME "libltdl"
>> #define PACKAGE_VERSION "2.1a"
>> #define PACKAGE_STRING "libltdl 2.1a"
>> #define PACKAGE_BUGREPORT "bug-libtool_at_[hidden]"
>> configure: exit 1
>> Thank you for your attention.Hope your reply.
>>
>>
>>
>>
>> haowp
>> Sep.15.2011
>>
>>
>>
>>
>> At 2011-09-15 00:32:32,"Ralph Castain" <rhc_at_[hidden]
>> > wrote:
>> >
>> >On Sep 14, 2011, at 9:39 AM, Blosch, Edwin L wrote:
>> >
>> >> Thanks, Ralph,
>> >>
>> >> I get the failure messages, unfortunately:
>> >>
>> >> setgid FAILED
>> >> setgid FAILED
>> >> setgid FAILED
>> >>
>> >> I actually had attempted to call setgid from within the application previously, which looks similar to what you've done, but it failed. That was when I initiated the post to the mailing list. My conclusion, a guess really, was that Linux would not let me setgid from within my program because I was not root.
>> >
>> >I was afraid of that - the documentation seemed to indicate that would be the case, but I figured it was worth a quick try. Sorry I can't be of help.
>> >
>> >
>> >>
>> >>
>> >> -----Original Message-----
>> >> From:
>> users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]
>> ] On Behalf Of Ralph Castain
>> >> Sent: Wednesday, September 14, 2011 8:15 AM
>> >> To: Open MPI Users
>> >> Subject: Re: [OMPI users] EXTERNAL: Re: Can you set the gid of the processes created by mpirun?
>> >>
>> >> The attached should set the gid of the remote daemons (and their children) to the gid of mpirun. No cmd line option or anything is required - it will just always do it.
>> >>
>> >> Would you mind giving it a try?
>> >>
>> >> Please let me know if/how it works.
>> >>
>> >> _______________________________________________
>> >> users mailing list
>> >>
>> users_at_[hidden]
>>
>> >>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> >
>> >
>> >_______________________________________________
>> >users mailing list
>> >
>> users_at_[hidden]
>>
>> >
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/