Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Problem compiling openmpi-1.4.3
From: Gus Correa (gus_at_[hidden])
Date: 2011-09-13 16:49:34

Hi Amos

Do you mean './configure' instead of './compile'?
Also, not sure if LIBDIRS is used by the OpenMPI configure script.

The second error (cannot load
may be because you need to set your
Intel compiler environment environment.
It is easier to put it in your .cshrc/.bashrc file.
Something like this:

source /opt/intel/composerxe-2011.5.220/compiler/bin/compilervars.csh

I guess mpicc won't do it for you when you compile a program,
and mpiexec won't do it either, when you run the program.

I hope this helps,
Gus Correa

Rayson Ho wrote:
> Did you notice the error message:
> /usr/bin/install: cannot remove
> `/opt/openmpi/share/openmpi/amca-param-sets/example.conf': Permission
> denied
> I would check the permission settings of the file first if I encounter
> something like this...
> Rayson
> =================================
> Grid Engine / Open Grid Scheduler
> On Tue, Sep 13, 2011 at 4:22 PM, amosleff_at_[hidden] <amosleff_at_[hidden]> wrote:
>> Dear Users,
>> I have run into a problem trying to compile openmpi-1.4.3. I am
>> running SuSE Linux 11.4 in VMware-7.0.1. For compilers I am using
>> l_fcompxe_intel64_2011.5.220 and l_ccompxe_intel64_2011.5.220 which are
>> newly issued. It appears to go through the compile command:
>> ./compile
>> LIBDIRS="/opt/intel/composerxe-2011.5.220/compiler/lib/intel64"
>> --prefix=/opt/openmpi CC=icc CXX=icpc F77=ifort F90=ifort
>> After running "make all install" the end of the output gives the error:
>> test -z "/opt/openmpi/share/openmpi/amca-param-sets" || /bin/mkdir -p
>> "/opt/openmpi/share/openmpi/amca-param-sets"
>> /usr/bin/install -c -m 644 'amca-param-sets/example.conf'
>> '/opt/openmpi/share/openmpi/amca-param-sets/example.conf'
>> /usr/bin/install: cannot remove
>> `/opt/openmpi/share/openmpi/amca-param-sets/example.conf': Permission denied
>> make[2]: *** [install-dist_amca_paramDATA] Error 1
>> make[2]: Leaving directory `/home/amos/Downloads/openmpi-1.4.3/contrib'
>> make[1]: *** [install-am] Error 2
>> make[1]: Leaving directory `/home/amos/Downloads/openmpi-1.4.3/contrib'
>> make: *** [install-recursive] Error 1
>> I have tried using examples trying to run one of the examples
>> and it gives an error
>> /Downloads/openmpi-1.4.3/examples> mpicc -np 4 connectivity_c.c
>> mpicc: error while loading shared libraries: cannot open shared
>> object file: No such file or directory
>> This is the reason for the LIBDIRS in the compiling command. I have run
>> into the same error trying to set up espresso-4.3.1. The result occurs
>> whether I use root or a user login. The file is present being the next
>> entry in the string in LIBDIRS.
>> Any help would be much appreciated.
>> Amos Leffler
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]