Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Question on using rsh
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-09-12 20:42:37


The two are synonyms for each other - they resolve to the identical variable, so there isn't anything different about them.

Not sure what the issue might be, but I would check for a typo - we don't check that mca params are spelled correctly, nor do we check for params that don't exist (e.g., because you spelled it wrong).

On Sep 12, 2011, at 3:03 PM, Blosch, Edwin L wrote:

> I have a hello world program that runs without prompting for password with plm_rsh_agent but not with orte_rsh_agent, I mean it runs but only after prompting for a password:
>
> <path>/bin/mpirun --machinefile mpihosts.dat -np 16 -mca plm_rsh_agent /usr/bin/rsh ./test_setup
>
> Hello from process 2
> Hello from process 5
> Hello from process 12
> Hello from process 6
> Hello from process 0
>
> Hello from process 4
> Hello from process 3
> Hello from process 7
> Hello from process 14
> Hello from process 8
> Hello from process 1
> Hello from process 9
> Hello from process &n bsp; 10
> Hello from process 11
> Hello from process 13
> Hello from process 15
>
> <path>bin/mpirun --machinefile mpihosts.dat -np 16 -mca orte_rsh_agent /usr/bin/rsh./test_setup
> bloscel_at_f8312's password:
>
> I didn’t notice anything about this in the FAQ except that orte_rsh_agent is newer than plm_rsh_agent. Did I miss some critical piece of information? Why do these options behave differently?
>
> Thanks
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users