Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] EXTERNAL: Re: qp memory allocation problem
From: Nathan Hjelm (hjelmn_at_[hidden])
Date: 2011-09-12 18:35:01


On Mon, 12 Sep 2011, Blosch, Edwin L wrote:

> It was set to 0 previously. We've set it to 4 and restarted some service and now it works. So both your and Samuel's suggestions worked.
>
> On another system, slightly older, it was defaulted to 3 instead of 0, and apparently that explains why the job always ran before and on this newer system did not run.
>
> I'm wondering if there was any way for us to know that this change had happened.

We stumbled across the change two weeks ago while setting up a new system. From what I understand the change had something to do with cache performance when using huge pages. Of course it breaks everything for those of us that aren't using huge pages. Though, to be fair, users *should* have been setting this parameter all along.

-Nathan
Los Alamos National Laboratory