Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI via SSH noob issue
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-08-11 08:07:36


On Aug 11, 2011, at 2:12 AM, Christopher Jones wrote:

> Ok - I see what I missed in the FAQ, sorry about that....my understanding of the shell is a bit minimal to say the least. I now have my .bashrc files configured as such on both computers:
>
> export LD_LIBRARY_PATH=/opt/local/openmpi/lib:{$PATH}
> export PATH=/opt/local/openmpi/bin:{$PATH}

Good!

> However, I am now running into a new issue that is still cryptic to me:
>
> quadcore:~ chrisjones$ /opt/local/openmpi/bin/mpirun -np 8 -hostfile hostfile ./ring_c
> Process 0 sending 10 to 1, tag 201 (8 processes in ring)
> [quadcore.mikrob.slu.se][[53435,1],0][btl_tcp_endpoint.c:638:mca_btl_tcp_endpoint_complete_connect] connect() to 127.0.0.1 failed: Connection refused (61)

This sounds like you have firewalls enabled on your machines.

Open MPI essentially requires the ability to open random TCP sockets between processes on all of the nodes that its running on. Can you disable the firewalls, or add implicit trust between all the nodes on which you'll be running?

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/