Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] and the next one (3th today!) PGI+OpenMPI issue
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-07-22 15:47:57


Could you try compiling a trunk nightly tarball of Open MPI?

We recently upgraded the version of Libtool that is used to bootstrap that tarball (compared to the v1.4 and v1.5 tarballs):

    http://www.open-mpi.org/nightly/trunk/

On Jul 22, 2011, at 12:13 PM, Paul Kapinos wrote:

> ... just do almost the same thing: Try to install OpenMPI 1.4.3 using 11.7 PGI Compiler on Scientific Linux 6.0. The same place, but other error message:
> ------------------------------------------------------------------------------
> /usr/lib64/crt1.o: In function `_start':
> (.text+0x20): undefined reference to `main'
> gmake[2]: *** [libmpi_cxx.la] Error 2
> gmake[2]: Leaving directory `/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux64_pgi/ompi/mpi/cxx'
> ------------------------------------------------------------------------------
>
> and then the compilation aborted. Configure string below. With the Intel, gcc and Studio compiles, the very same installations were happily through.
>
> Maybe someone can give me a hint about this is an issue by openmpi, pgi or somehow else...
>
> Best wishes,
>
> Paul
>
> P.S.
>
> again, more logs downloadable:
> https://gigamove.rz.rwth-aachen.de/d/id/WNk69nPr4w7svT
>
>
> --
> Dipl.-Inform. Paul Kapinos - High Performance Computing,
> RWTH Aachen University, Center for Computing and Communication
> Seffenter Weg 23, D 52074 Aachen (Germany)
> Tel: +49 241/80-24915
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/