Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] One more pgi+libtool issue
From: Paul Kapinos (kapinos_at_[hidden])
Date: 2011-07-22 12:01:54


Hi,

One more libtool/openMPI issue.

Installing OpenMPI in version 1.4.3 using the 11.7 PGI compilers in 32
bit, I get a compilation error:

------------------------------------------------------------------------------
../../../ompi/.libs/libmpi.so: could not read symbols: File in wrong format
gmake[2]: *** [libmpi_cxx.la] Error 2
gmake[2]: Leaving directory
`/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/ompi/mpi/cxx'
------------------------------------------------------------------------------

invoking just the same link line as in my previous mail (I didn't
realize the real error by first time, sorry):

------------------------------------------------------------------------------
libtool: link: pgCC --prelink_objects --instantiation_dir Template.dir
   .libs/mpicxx.o .libs/intercepts.o .libs/comm.o .libs/datatype.o
.libs/win.o .libs/file.o -Wl,--rpath
-Wl,/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/ompi/.libs
-Wl,--rpath
-Wl,/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/orte/.libs
-Wl,--rpath
-Wl,/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/opal/.libs
-Wl,--rpath -Wl,/opt/MPI/openmpi-1.4.3/linux/pgi/lib/lib32
-L/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/orte/.libs
-L/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/opal/.libs
-L/opt/lsf/8.0/linux2.6-glibc2.3-x86/lib ../../../ompi/.libs/libmpi.so
/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/orte/.libs/libopen-rte.so
/tmp/pk224850/linuxc2_11254/openmpi-1.4.3_linux32_pgi/opal/.libs/libopen-pal.so
-ldl -lnsl -lutil
------------------------------------------------------------------------------

So, ../../../ompi/.libs/libmpi.so is 32bit file, the pgCC defaults to
64bit, and there is no -m32 swith in the command line.

BUT, in the configure line (below) I get the -m32 flag!! So, where is
the -m32 thing lost? Did I do something in a wrong way?

Best wishes and a nice weekend,

Paul Kapinos

P.S. again, the some more logs downloadable from here:
https://gigamove.rz.rwth-aachen.de/d/id/xoQ2DnUDf4Trjo

------------------------------------------------------------------------------
   $ ./configure --with-openib --with-lsf --with-devel-headers
--enable-contrib-no-build=vt --enable-heterogeneous
--enable-cxx-exceptions --enable-orterun-prefix-by-default
CFLAGS=-fastsse -m32 CXXFLAGS=-fastsse -m32 FFLAGS=-fastsse -m32
FCFLAGS=-fastsse -m32 LDFLAGS=-fastsse -m32
-L/opt/lsf/8.0/linux2.6-glibc2.3-x86/lib
--prefix=/opt/MPI/openmpi-1.4.3/linux/pgi
--mandir=/opt/MPI/openmpi-1.4.3/linux/pgi/man
--bindir=/opt/MPI/openmpi-1.4.3/linux/pgi/bin/32
--libdir=/opt/MPI/openmpi-1.4.3/linux/pgi/lib/lib32
--includedir=/opt/MPI/openmpi-1.4.3/linux/pgi/include/32 CC=pgcc
CXX=pgCC F77=pgf77 FC=pgf90 --enable-ltdl-convenience --no-create
--no-recursion
------------------------------------------------------------------------------

-- 
Dipl.-Inform. Paul Kapinos   -   High Performance Computing,
RWTH Aachen University, Center for Computing and Communication
Seffenter Weg 23,  D 52074  Aachen (Germany)
Tel: +49 241/80-24915