Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] The hostfile could not be found
From: zhuangchao (freeoser_at_[hidden])
Date: 2011-06-30 22:24:06


hello all ,

     I submited the following Torque/pbs script.

     #PBS -e /tmp/blast_19297.err
     #PBS -o /tmp/blast.output
     mpiexec -d -machinefile /tmp/nodes.19297.txt -np 3 /data1/bin/mpiblast -p tblastx -i /data1/cluster/sequences/seq_4.txt -d nt -o /data1/cluster/blast.out/blast.out.19297 -g T -m 0 -F F

     Then I got the following error from openmpi. But it is ok if I run the above mpiexec command
in the bash shell. Can you help me ? Thank you very much !

n-1<18242> ssi:boot:base: looking for boot schema in following directories:
n-1<18242> ssi:boot:base: <current directory>
n-1<18242> ssi:boot:base: $TROLLIUSHOME/etc
n-1<18242> ssi:boot:base: $LAMHOME/etc
n-1<18242> ssi:boot:base: /data1/lam-mpi/etc
n-1<18242> ssi:boot:base: looking for boot schema file:
n-1<18242> ssi:boot:base: /tmp/nodes.19297.txt
n-1<18242> ssi:boot:base: found boot schema: Not found!
-----------------------------------------------------------------------------
The hostfile "/tmp/nodes.19297.txt" could not be found:
        Unix errno: 2
        No such file or directory
Things to check:
        - ensure that the file exists
          try "ls -l /tmp/nodes.19297.txt"
        - ensure that you have read permissions on the file
          try "cat /tmp/nodes.19297.txt"
-----------------------------------------------------------------------------
-----------------------------------------------------------------------------
It seems that there is no lamd running on the host node2.
This indicates that the LAM/MPI runtime environment is not operating.
The LAM/MPI runtime environment is necessary for the "lamhalt" command.
Please run the "lamboot" command the start the LAM/MPI runtime
environment. See the LAM/MPI documentation for how to invoke
"lamboot" across multiple machines.