Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Building OpenMPI v. 1.4.3 in VS2008
From: Shiqing Fan (fan_at_[hidden])
Date: 2011-06-27 04:33:07


Hi Alan,

> Thanks Shiqing,
>
> It turns out that I was able to get the build to work in VS2008, by
> stepping back to CMake 2.6 to build it. Not sure why that did the
> trick but I'm not complaining...
>

Which version did you use before?

> Another question: Is it possible to run an OpenMPI-based executable
> on a single process, without invoking mpiexec? Say for example that I
> compiled a simple "Hello world" program such as
> src/examples/hello_cxx.cc that calls MPI_Init(...). I'd like to start
> it up (as a serial process) by just calling it from the command line,
> without reference to mpiexec. Can this be done? If so, could you
> provide an example syntax? I'm used to doing this with MPICH2, where
> it works with no problem.
>

Yes, just run your compiled hello_cxx.exe in the command line prompt,
nothing special.

Regards,
Shiqing

> Thanks,
>
> Alan Nichols
>
> AWR - STAAR
>
> 11520 N. Port Washington Rd.
>
> Mequon, WI 53092
>
> P: 1.262.240.0291 x 103
>
> F: 1.262.240.0294
>
> E: anichols_at_[hidden] <mailto:anichols_at_[hidden]>
>
> http://www.awrcorp.com <http://www.awrcorp.com/>
>
> *From:*Shiqing Fan [mailto:fan_at_[hidden]]
> *Sent:* Tuesday, June 21, 2011 3:10 AM
> *To:* Alan Nichols
> *Cc:* Open MPI Users
> *Subject:* Re: [OMPI users] Building OpenMPI v. 1.4.3 in VS2008
>
>
> Hi Alan,
>
> I was able to test it again on a machine that has a VS2008 installed.
> But everything worked just fine for me. I looked into the generated
> config file(build_dir/opal/include/opal_config.h), and the CMake build
> system didn't find stdint.h, but it still compiled.
>
> So it was probably some other issues on your platform. It would be
> very helpful for me to figure out the problem, if you can provide more
> information, e.g. configure log, compilation error messages and so on.
>
>
> Regards,
> Shiqing
>
> On 2011-06-10 8:34 PM, Alan Nichols wrote:
>
> Hi Shiquing,
>
> OK I'll give this a try... however, I realized after some Google
> searching in the aftermath of my previous attempt to build on VS2008
> that the file that I'm missing on that platform is shipped with VS2010.
>
> So I suspect that building on VS2010 will go smoothly as you said. My
> problem is that my current effort is part of a much larger project
> that is being built on VS2008. On the one hand I don't want at all to
> shift that larger code base from VS2008 to VS2010 (and fight the
> numerous problems that always follow an upheaval of that sort); on the
> other hand I'm dubious about trying to build my parallel support
> library on VS2010 and the rest of the code on VS2008.
>
> Is there a way to do what I really want to do, which is build the
> openmpi source on VS2008?
>
> Alan Nichols
>
> AWR - STAAR
>
> 11520 N. Port Washington Rd.
>
> Mequon, WI 53092
>
> P: 1.262.240.0291 x 103
>
> F: 1.262.240.0294
>
> E: anichols_at_[hidden] <mailto:anichols_at_[hidden]>
>
> http://www.awrcorp.com <http://www.awrcorp.com/>
>
> *From:*Shiqing Fan [mailto:fan_at_[hidden]]
> *Sent:* Thursday, June 09, 2011 6:43 PM
> *To:* Open MPI Users
> *Cc:* Alan Nichols
> *Subject:* Re: [OMPI users] Building OpenMPI v. 1.4.3 in VS2008
>
>
> Hi Alan,
>
> It looks like a problem of using a wrong generator in CMake GUI. I
> double tested a fresh new downloaded 1.4.3 on my win7 machine with
> VS2010, everything worked well.
>
> Please check:
> 1. a proper CMake generator is used.
> 2. the CMAKE_BUILD_TYPE in CMake GUI and the build type in VS are
> both Release
>
> If the error still happens, please provide me the file name and line
> number where triggers the error when compiling it.
>
> Regards,
> Shiqing
>
> On 2011-06-07 5:37 PM, Alan Nichols wrote:
>
> Hello,
>
> I'm currently trying to build OpenMPI v. 1.4.3 from source, in
> VS2008. Platform is Win7, SP1 installed ( I realize that this is
> possibly not an ideal approach as v. 1.5.3 has installers for Windows
> binaries. However for compatibility with other programs I need to use
> v. 1.4.3 if at all possible; also as I have many other libraries
> build under VS2008, I need to use the VS2008 compiler if at all possible).
>
> Following the README.WINDOWS file I found, I used CMake to build a
> Windows .sln file. I accepted the default CMake settings, with the
> exception that I only created a Release build of OpenMPI. Upon my
> first attempt to build the solution, I got an error about a missing
> file stdint.h. I was able to fix this by including the stdint.h from
> VS2010. However I now get new errors referencing
>
> __attribute__((__always_inline__))
>
> __asm____volatile__("": : :"memory")
>
> These look to me like linux-specific problems -- is it even possible
> to do what I'm attempting, or are the code bases and compiler
> fundamentally at odds here? If it is possible can you explain where
> my error lies?
>
> Thanks for your help,
>
> Alan Nichols
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden] <mailto:users_at_[hidden]>
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
>
>
> --
> ---------------------------------------------------------------
> Shiqing Fan
> High Performance Computing Center Stuttgart (HLRS)
> Tel: ++49(0)711-685-87234 Nobelstrasse 19
> Fax: ++49(0)711-685-65832 70569 Stuttgart
> http://www.hlrs.de/organization/people/shiqing-fan/
> email:fan_at_[hidden] <mailto:fan_at_[hidden]>
>
>
>
>
> --
> ---------------------------------------------------------------
> Shiqing Fan
> High Performance Computing Center Stuttgart (HLRS)
> Tel: ++49(0)711-685-87234 Nobelstrasse 19
> Fax: ++49(0)711-685-65832 70569 Stuttgart
> http://www.hlrs.de/organization/people/shiqing-fan/
> email:fan_at_[hidden] <mailto:fan_at_[hidden]>

-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]