Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpif90 compiler non-functional
From: Dmitry N. Mikushin (maemarcus_at_[hidden])
Date: 2011-06-22 12:05:17


Here's mine produced from default compilation:

                 Package: Open MPI marcusmae_at_T61p Distribution
                Open MPI: 1.4.4rc2
   Open MPI SVN revision: r24683
   Open MPI release date: May 05, 2011
                Open RTE: 1.4.4rc2
   Open RTE SVN revision: r24683
   Open RTE release date: May 05, 2011
                    OPAL: 1.4.4rc2
       OPAL SVN revision: r24683
       OPAL release date: May 05, 2011
            Ident string: 1.4.4rc2
                  Prefix: /opt/openmpi_gcc-1.4.4
 Configured architecture: x86_64-unknown-linux-gnu
          Configure host: T61p
           Configured by: marcusmae
           Configured on: Tue May 24 18:39:21 MSD 2011
          Configure host: T61p
                Built by: marcusmae
                Built on: Tue May 24 18:46:52 MSD 2011
              Built host: T61p
              C bindings: yes
            C++ bindings: yes
      Fortran77 bindings: yes (all)
      Fortran90 bindings: yes
 Fortran90 bindings size: small
              C compiler: gcc
     C compiler absolute: /usr/bin/gcc
            C++ compiler: g++
   C++ compiler absolute: /usr/bin/g++
      Fortran77 compiler: gfortran
  Fortran77 compiler abs: /usr/bin/gfortran
      Fortran90 compiler: gfortran
  Fortran90 compiler abs: /usr/bin/gfortran

gfortran version is:

gcc version 4.6.0 20110530 (Red Hat 4.6.0-9) (GCC)

How do you run ./configure? Maybe try "./configure
FC=/usr/bin/gfortran" ? It should really really work out of box
though. Configure scripts usually cook some simple test apps and run
them to check if compiler works properly. So, your ./configure output
may help to understand more.

- D.

2011/6/22 Alexandre Souza <costamfix_at_[hidden]>:
> Hi Dimitri,
> Thanks for the reply.
> I have openmpi installed before for another application in :
> /home/amscosta/OpenFOAM/ThirdParty-1.7.x/platforms/linuxGcc/openmpi-1.4.1
> I installed a new version in /opt/openmpi-1.4.3.
> I reproduce some output from the screen :
> amscosta_at_amscosta-desktop:/opt/openmpi-1.4.3/bin$ ompi_info
>                 Package: Open MPI amscosta_at_amscosta-desktop Distribution
>                Open MPI: 1.4.1
>   Open MPI SVN revision: r22421
>   Open MPI release date: Jan 14, 2010
>                Open RTE: 1.4.1
>   Open RTE SVN revision: r22421
>   Open RTE release date: Jan 14, 2010
>                    OPAL: 1.4.1
>       OPAL SVN revision: r22421
>       OPAL release date: Jan 14, 2010
>            Ident string: 1.4.1
>                  Prefix:
> /home/amscosta/OpenFOAM/ThirdParty-1.7.x/platforms/linuxGcc/openmpi-1.4.1
>  Configured architecture: i686-pc-linux-gnu
>          Configure host: amscosta-desktop
>           Configured by: amscosta
>           Configured on: Wed May 18 11:10:14 BRT 2011
>          Configure host: amscosta-desktop
>                Built by: amscosta
>                Built on: Wed May 18 11:16:21 BRT 2011
>              Built host: amscosta-desktop
>              C bindings: yes
>            C++ bindings: no
>      Fortran77 bindings: no
>      Fortran90 bindings: no
>  Fortran90 bindings size: na
>              C compiler: gcc
>     C compiler absolute: /usr/bin/gcc
>            C++ compiler: g++
>   C++ compiler absolute: /usr/bin/g++
>      Fortran77 compiler: gfortran
>  Fortran77 compiler abs: /usr/bin/gfortran
>      Fortran90 compiler: none
>  Fortran90 compiler abs: none
>             C profiling: no
>           C++ profiling: no
>     Fortran77 profiling: no
>     Fortran90 profiling: no
>          C++ exceptions: no
>          Thread support: posix (mpi: no, progress: no)
>           Sparse Groups: no
>  Internal debug support: no
>     MPI parameter check: runtime
> Memory profiling support: no
> Memory debugging support: no
>         libltdl support: yes
>   Heterogeneous support: no
>  mpirun default --prefix: no
>         MPI I/O support: yes
>       MPI_WTIME support: gettimeofday
> Symbol visibility support: yes
>  ......
>
>
> On Wed, Jun 22, 2011 at 12:34 PM, Dmitry N. Mikushin
> <maemarcus_at_[hidden]> wrote:
>> Alexandre,
>>
>> Did you have a working Fortran compiler in system in time of OpenMPI
>> compilation? To my experience Fortran bindings are always compiled by
>> default. How did you configured it and have you noticed any messages
>> reg. Fortran support in configure output?
>>
>> - D.
>>
>> 2011/6/22 Alexandre Souza <costamfix_at_[hidden]>:
>>> Dear Group,
>>> After compiling the openmpi source, the following message is displayed
>>> when trying to compile
>>> the hello program in fortran :
>>> amscosta_at_amscosta-desktop:~/openmpi-1.4.3/examples$
>>> /opt/openmpi-1.4.3/bin/mpif90 -g hello_f90.f90 -o hello_f90
>>> --------------------------------------------------------------------------
>>> Unfortunately, this installation of Open MPI was not compiled with
>>> Fortran 90 support.  As such, the mpif90 compiler is non-functional.
>>> --------------------------------------------------------------------------
>>> Any clue how to solve it is very welcome.
>>> Thanks,
>>> Alex
>>> P.S. I am using a ubuntu box with gfortran
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>