Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Conflicting versions of libgfortran.so with mpif90? Solved!
From: Michael Cugley (Michael.Cugley_at_[hidden])
Date: 2011-06-16 10:18:03


On June 14, 2011 at 12:35 PM, Jeff Squyres wrote:
>
> Are they using a different version of gfortran to compile / link their
> application than what was used to compile / build Open MPI?
>
> FWIW: it's typically easier to use the same compilers to build Open
> MPI as the application.
>
>

That did, in fact, turn out to be the problem. After some head
scratching and the mighty Google, I found this page:
https://www.scotgrid.ac.uk/wiki/index.php/Building_OPENMPI which
(amongst other things) gave me the requisite flags to feed configure.

Oddly, ldd on the resulting executable still shows references to
libgfortran.so.3 and .so.1, but the warnings are gone and the user is
happy, so I'm counting it as a victory.

-- 
Michael Cugley
School of Engineering IT Support
M.Cugley_at_[hidden]
Please direct IT support queries to itsupport_at_[hidden]