Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Conflicting versions of libgfortran.so with mpif90?
From: Michael Cugley (Michael.Cugley_at_[hidden])
Date: 2011-06-14 12:02:27


I do IT support for people who are using OpenMPI for research. However,
they are reporting the following warnings when compiling code with mpif90:

/usr/bin/ld: warning: libgfortran.so.1, needed by
/usr/lib64/openmpi/1.4-gcc/lib/libmpi_f90.so, may conflict with
libgfortran.so.3

Running ldd on the resulting executable gives:

     libmpi_f90.so.0 => /usr/lib64/openmpi/1.4-gcc/lib/libmpi_f90.so.0
(0x00002b5aac251000)
     libmpi_f77.so.0 => /usr/lib64/openmpi/1.4-gcc/lib/libmpi_f77.so.0
(0x00002b5aac454000)
     libmpi.so.0 => /usr/lib64/openmpi/1.4-gcc/lib/libmpi.so.0
(0x0000003df3600000)
     libopen-rte.so.0 => /usr/lib64/openmpi/1.4-gcc/lib/libopen-rte.so.0
(0x0000003df1a00000)
     libopen-pal.so.0 => /usr/lib64/openmpi/1.4-gcc/lib/libopen-pal.so.0
(0x0000003df1e00000)
     libdl.so.2 => /lib64/libdl.so.2 (0x0000003df2e00000)
     libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003df2200000)
     libutil.so.1 => /lib64/libutil.so.1 (0x0000003dff400000)
     libgfortran.so.3 => /usr/lib64/libgfortran.so.3 (0x00002b5aac6a3000)
     libm.so.6 => /lib64/libm.so.6 (0x0000003df2a00000)
     libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003e02c00000)
     libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003df3200000)
     libc.so.6 => /lib64/libc.so.6 (0x0000003df2600000)
     libgfortran.so.1 => /usr/lib64/libgfortran.so.1 (0x00002b5aac999000)
     /lib64/ld-linux-x86-64.so.2 (0x0000003df1600000)

It looks like there are attempts to link to two versions of libgfortran,
which aren't compatible.

I'm not familiar with OpenMPI myself, but the people using it would like
to know how these warnings can be dealt with.

-- 
Michael Cugley
School of Engineering IT Support
M.Cugley_at_[hidden]
Please direct IT support queries to itsupport_at_[hidden]