Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ifort 12.0.4 install problem
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-06-06 20:56:31


On Jun 6, 2011, at 10:43 AM, Virginie trinite wrote:

> I try to compile open-mpi with ifort 12.0.4. My system is ubuntu
> lucid. Previous intallation with ifort 11.1 was fine.
>
> configure and make all seems to work well, but make install report an error:
> libtool: line 7847: icc: command not found
> libtool: install: error: relink `lipopen-rte.la' with the above
> command before installing it
>
> I want to underline that icc is a knom command for bash.

Somehow it became unknown. Is your PATH being reset somehow? Or perhaps if your .bashrc resetting your PATH such that even if "which icc" finds it at the shell prompt, if sub-shells have your .bashrc invoked, the PATH gets reset (or the icc settings don't get inherited properly), and therefore it becomes unknown...?

> I have check the FAQ and it seems to me that the problem is more like
> the one report for IBM compiler. So I try with

I'm a little confused why you're mentioning the IBM compiler...? This issue is a shell/build issue (I assume...? You only sent a few lines from the output, so I can't tell exactly where the error is occurring).

> configure CC=icc CXX=icpc F77=ifort FC=ifort --disable-shared --enable-static
> Now the install finish without error, but when I try to run mpi I have
> error message:

Now I'm very confused. :-\

Can you please send all the information listed here:

    http://www.open-mpi.org/community/help/

This will help me understand what the problem is and what you tried to do to fix it.

Thanks.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/