Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with MPI_Intercomm_create
From: David Zhang (solarbikedz_at_[hidden])
Date: 2011-06-02 00:23:41


Since your new intra-communicator contains all members, couldn't you
just use the MPI_COMM_WORLD communicator?

2011/6/1 Frédéric Feyel <mcffeyel_at_[hidden]>:
> Hello,
>
> I have a problem using MPI_Intercomm_create.
>
> I 5 tasks, let's say T0, T1, T2, T3, T4 resulting from two spawn
> operations by T0.
>
> So I have two intra-communicator :
>
> intra0 contains : T0, T1, T2
> intra1 contains : T0, T3, T4
>
> my goal is to make a collective loop to build a single intra-communicator
> containing T0, T1, T2, T3, T4
>
> I tried to do it using MPI_Intercomm_create and MPI_Intercom_merge calls,
> but without success (I always get MPI internal errors).
>
> What I am doing :
>
> on T0 :
> *******
>
> MPI_Intercom_create(intra0,0,intra1,0,1,&new_com)
>
> on T1 and T2 :
> **************
>
> MPI_Intercom_create(intra0,0,MPI_COMM_WORLD,0,1,&new_com)
>
> on T3 and T4 :
> **************
>
> MPI_Intercom_create(intra1,0,MPI_COMM_WORLD,0,1,&new_com)
>
>
> I'm certainly missing something. Could anybody help me to solve this
> problem ?
>
> Best regards,
>
> Frédéric.
>
> PS : of course I did an extensive web search without finding anything
> usefull on my problem.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
David Zhang
University of California, San Diego