Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mpi.h:: OMPI_HAVE_FORTRAN_LOGICAL / INTEGER / REAL are set to 0 (zero)
From: hi (hiralsmaillist_at_[hidden])
Date: 2011-05-31 08:32:15


Greetings once again !!!

Environment:
OS: Windows 7 64-bit
Compilers: ifort and cl.exe (both 64-bit)
CMAKE: version-2.8.4
OpenMPI: version 1.5.3

As described in the README.WINDOWS.txt, when performing 'First
approach:" I am observing following...
1) via cmake-gui.exe clicked 'Configure' and it shown all config
options in pink color
    see output of this step in attached cmake_gui_output1.txt
2) then I enabled OMPI_WANT_F77_BINDING and OMPI_WANT_F90_BINDING to
true and then clicked 'Configure'.
    see output of this step in attached cmake_gui_output2.txt

As you can observe in cmake_gui_output2.txt file, it succeeded on all
Fortran data types (except INTEGER*16 and REAL*2).
Now what I am observing is that eventho' fortran compiler supports
most of the datatypes, but still mpi.h file reports '0' for
corresponding datatype.
<from_mpi.h>
/* Whether we have FORTRAN LOGICAL*1 or not */
#define OMPI_HAVE_FORTRAN_LOGICAL1 0

/* Whether we have FORTRAN LOGICAL*2 or not */
#define OMPI_HAVE_FORTRAN_LOGICAL2 0

/* Whether we have FORTRAN LOGICAL*4 or not */
#define OMPI_HAVE_FORTRAN_LOGICAL4 0

/* Whether we have FORTRAN LOGICAL*8 or not */
#define OMPI_HAVE_FORTRAN_LOGICAL8 0

/* Whether we have FORTRAN INTEGER*1 or not */
#define OMPI_HAVE_FORTRAN_INTEGER1 0

/* Whether we have FORTRAN INTEGER*16 or not */
#define OMPI_HAVE_FORTRAN_INTEGER16 0

/* Whether we have FORTRAN INTEGER*2 or not */
#define OMPI_HAVE_FORTRAN_INTEGER2 0

/* Whether we have FORTRAN INTEGER*4 or not */
#define OMPI_HAVE_FORTRAN_INTEGER4 0

/* Whether we have FORTRAN INTEGER*8 or not */
#define OMPI_HAVE_FORTRAN_INTEGER8 0

/* Whether we have FORTRAN REAL*16 or not */
#define OMPI_HAVE_FORTRAN_REAL16 0

/* Whether we have FORTRAN REAL*2 or not */
#define OMPI_HAVE_FORTRAN_REAL2 0

/* Whether we have FORTRAN REAL*4 or not */
#define OMPI_HAVE_FORTRAN_REAL4 0

/* Whether we have FORTRAN REAL*8 or not */
#define OMPI_HAVE_FORTRAN_REAL8 0
======

Any idea on why mpi.h is setting zero for all above fortran datatypes
despite fortran compiler supports most of the datatypes (see
cmake_gui_output2.txt)???

Thank you in advance.
-Hiral