Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Symbol not found: _evsignal_base
From: charles reid (charlesreid1_at_[hidden])
Date: 2011-05-26 15:16:03


Hi Jeff & others -

Thanks for the response. OpenMPI compiles fine, so there are no problems
with the make process, but I can't run "mpirun" because the program won't
compile with mpicc - this case isn't really covered by the "Getting Help"
page. However, I have provided the output of configure/make/make install,
even though it was successful. The .tar.gz file is here:

http://files.charlesmartinreid.com/openmpi_out.tar.gz

If there is any additional info that would be helpful, please let me know.

Charles

On Wed, May 25, 2011 at 17:27, Jeff Squyres <jsquyres_at_[hidden]> wrote:

> This looks like your installation is busted somehow. Can you send all the
> information listed here:
>
> http://www.open-mpi.org/community/help/
>
>
> On May 24, 2011, at 4:05 PM, charles reid wrote:
>
> > Hi -
> >
> > I'm trying to compile a simple hello world program with mpicc,
> >
> > $ cat test.c
> > #include <stdio.h>
> >
> > main()
> > {
> > printf ("Hello World!\n");
> > }
> >
> >
> > but I'm seeing this issue:
> >
> > $ ~/pkg/openmpi/1.4.3_bigmac/bin/mpicc test.c
> > dyld: Symbol not found: _evsignal_base
> > Referenced from: /uufs/
> chpc.utah.edu/common/home/u0552682/pkg/openmpi/1.4.3_bigmac/lib/libopen-pal.0.dylib
> > Expected in: flat namespace
> > in /uufs/
> chpc.utah.edu/common/home/u0552682/pkg/openmpi/1.4.3_bigmac/lib/libopen-pal.0.dylib
> > Trace/BPT trap
> >
> >
> > I found this previous thread,
> http://comments.gmane.org/gmane.comp.clustering.open-mpi.user/13033 ,
> which suggested adding the installation directory's lib/ to LD_LIBRARY_PATH
> would fix things, but it did not:
> >
> > $ export
> LD_LIBRARY_PATH="${HOME}/pkg/openmpi/1.4.3_bigmac/lib:${LD_LIBRARY_PATH}";
> ~/pkg/openmpi/1.4.3_bigmac/bin/mpicc test.c
> > dyld: Symbol not found: _evsignal_base
> > Referenced from: /uufs/
> chpc.utah.edu/common/home/u0552682/pkg/openmpi/1.4.3_bigmac/lib/libopen-pal.0.dylib
> > Expected in: flat namespace
> > in /uufs/
> chpc.utah.edu/common/home/u0552682/pkg/openmpi/1.4.3_bigmac/lib/libopen-pal.0.dylib
> > Trace/BPT trap
> >
> >
> > Any suggestions on what I might be doing wrong?
> >
> >
> > Charles
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>