Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] MPI_Alltoallv function crashes when np > 100
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-05-20 07:26:19


I missed this email in my INBOX, sorry.

Can you be more specific about what exact error is occurring? You just say that the application crashes...? Please send all the information listed here:

    http://www.open-mpi.org/community/help/

On Apr 26, 2011, at 10:51 PM, ÃÏÏܾü wrote:

> It seems that the const variable SOMAXCONN who used by listen() system call causes this problem. Can anybody help me resolve this question?
>
> 2011/4/25 ÃÏÏܾü <xjun.meng_at_[hidden]>
> Dear all,
>
> As I mentioned, when I mpiruned an application with the parameter "np = 150(or bigger)", the application who used the MPI_Alltoallv function would carsh. The problem would recur no matter how many nodes we used.
>
> The edition of OpenMPI: 1.4.1 or 1.4.3
> The OS: linux redhat 2.6.32
>
> BTW, my nodes had enough memory to run the application, and the MPI_Alltoall function worked well at my environment.
> Did anybody meet the same problem? Thanks.
>
>
> Best Regards
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/