Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Sorry! You were supposed to get help about: But couldn't open help-orterun.txt
From: hi (hiralsmaillist_at_[hidden])
Date: 2011-05-19 03:55:09


Hi Ralph,

I tried following...
1) C:\test> mpirun -mca orte_headnode_name <hostname> <executable_name>
    where <hostname> is returned by 'hostname' command.
2) C:\test> mpirun -mca ras ^ccp <executable_name>

but still observing same errors...

BTW: for further inforamtion on ompi_info you can see thread
http://www.open-mpi.org/community/lists/users/2011/05/16554.php

Thank you.
-Hiral

On 5/18/11, Ralph Castain <rhc_at_[hidden]> wrote:
> I'm no Windozer, and our developer in that area is away for awhile. However,
> looking over the code, I can see where this might be failing.
>
> The Win allocator appears to be trying to connect to some cluster server -
> failing that, it aborts.
>
> If you just want to launch local, I would suggest adding "-mca ras ^ccp" to
> your mpirun cmd line. This will allow the system to pickup the local host
> and use it.
>
> BTW: your orte_headnode_name value is supposed to be whatever is returned by
> the "hostname" command on your head node (probably the node where you are
> executing mpirun), not the literal "HEADNODE_NAME" string. You might try it
> with that correction as well.
>
>
> On May 18, 2011, at 4:26 AM, hi wrote:
>
>> Any comment / suggestion on how to resolve this?
>>
>> Thank you.
>> -Hiral
>>
>> On 5/12/11, hi <hiralsmaillist_at_[hidden]> wrote:
>>> Hi,
>>>
>>> Clarifications:
>>> - I have downloaded pre-build OpenMPI_v1..5.3-x64 from open-mpi.org
>>> - installed it on Window 7
>>> - and then copied OpenMPI_v1..5.3-x64 directory from Windows 7 to
>>> Windows Server 2008 into different directory and also in same
>>> directory
>>>
>>> Now on Windows Server 2008, I am observing these errors...
>>>
>>> c:\ompi_tests\win64>mpirun mar_f_i_op.exe
>>> [nbld-w08:04820] [[30632,0],0] ORTE_ERROR_LOG: Error in file
>>> ..\..\..\openmpi-1.5.3\orte\mca\ras\base\ras_base_allocate.c at line
>>> 147
>>> [nbld-w08:04820] [[30632,0],0] ORTE_ERROR_LOG: Error in file
>>> ..\..\..\openmpi-1.5.3\orte\mca\plm\base\plm_base_launch_support.c at
>>> line 99
>>> [nbld-w08:04820] [[30632,0],0] ORTE_ERROR_LOG: Error in file
>>> ..\..\..\openmpi-1.5.3\orte\mca\plm\ccp\plm_ccp_module.c at line 186
>>> =
>>>
>>> As suggested, I tried with following but nothing worked...
>>> - copied to the same directory as it was in previous machine
>>> - executed "mpirun -mca orte_headnode_name HEADNODE_NAME" and "mpirun
>>> -mca orte_headnode_name MYHOSTNAME"
>>> - set OPENMPI_HOME and other OPAL_* env variables as follow...
>>>
>>> set OPENMPI_HOME=C:\MPIs\OpenMPI_v1.5.3-x64
>>> set OPAL_PREFIX=C:\MPIs\OpenMPI_v1.5.3-x64
>>> set OPAL_EXEC_PREFIX=C:\MPIs\OpenMPI_v1.5.3-x64
>>> set OPAL_BINDIR=C:\MPIs\OpenMPI_v1.5.3-x64\bin
>>> set OPAL_SBINDIR=C:\MPIs\OpenMPI_v1.5.3-x64\sbin
>>> set OPAL_LIBEXECDIR=C:\MPIs\OpenMPI_v1.5.3-x64\libexec
>>> set OPAL_DATAROOTDIR=C:\MPIs\OpenMPI_v1.5.3-x64\share
>>> set OPAL_DATADIR=C:\MPIs\OpenMPI_v1.5.3-x64\share
>>> set OPAL_SYSCONFDIR=C:\MPIs\OpenMPI_v1.5.3-x64\etc
>>> set OPAL_LOCALSTATEDIR=C:\MPIs\OpenMPI_v1.5.3-x64\etc
>>> set OPAL_LIBDIR=C:\MPIs\OpenMPI_v1.5.3-x64\lib
>>> set OPAL_INCLUDEDIR=C:\MPIs\OpenMPI_v1.5.3-x64\include
>>> set OPAL_INFODIR=C:\MPIs\OpenMPI_v1.5.3-x64\share\info
>>> set OPAL_MANDIR=C:\MPIs\OpenMPI_v1.5.3-x64\share\man
>>> set OPAL_PKGDATADIR=C:\MPIs\OpenMPI_v1.5.3-x64\share\openmpi
>>> set OPAL_PKGLIBDIR=C:\MPIs\OpenMPI_v1.5.3-x64\lib\openmpi
>>> set OPAL_PKGINCLUDEDIR=C:\MPIs\OpenMPI_v1.5.3-x64\include\openmpi
>>>
>>> Please correct if I missed any other env variable.
>>>
>>> Thank you.
>>> -Hiral
>>>
>>>
>>> On Wed, May 11, 2011 at 8:56 PM, Shiqing Fan <hpcfan_at_[hidden]> wrote:
>>>> Hi,
>>>>
>>>> The error message means that Open MPI couldn't allocate any compute
>>>> node.
>>>> It might because the headnode wasn't discovered. You could try with
>>>> option
>>>> "-mca orte_headnode_name HEADNODE_NAME" in the mpirun command line
>>>> (mpirun
>>>> --help will show how to use it) .
>>>>
>>>> And Jeff is also right, special care should be taken for the executable
>>>> paths, and it's better to use UNC path.
>>>>
>>>> To clarify the path issue, if you just copy the OMPI dir to another
>>>> computer, there might also be another problem that OMPI couldn't load
>>>> the
>>>> registry entries, as the registry entries were set during the
>>>> installation
>>>> phase on the specific computer. In 1.5.3, a overall env "OPENMPI_HOME"
>>>> will do the work.
>>>>
>>>> Regards,
>>>> Shiqing
>>>> ----- ԭʼÓʼþ -----
>>>> ·¢¼þÈË: Jeff Squyres <jsquyres_at_[hidden]>
>>>> ÊÕ¼þÈË: Open MPI Users <users_at_[hidden]>
>>>> ÒÑ·¢ËÍÓʼþ: Wed, 11 May 2011 15:21:26 +0200 (CEST)
>>>> Ö÷Ìâ: Re: [OMPI users] Sorry! You were supposed to get help about: But
>>>> couldn't open help-orterun.txt
>>>>
>>>> On May 11, 2011, at 5:50 AM, Ralph Castain wrote:
>>>>
>>>>>> Clarification: I installed pre-built OpenMPI_v1.5.3-x64 on Windows 7
>>>>>> and copied this directory into Windows Server 2008.
>>>>
>>>> Did you copy OMPI to the same directory tree that you built it?
>>>>
>>>> OMPI hard-codes some directory names when it builds, and it expects to
>>>> find that directory structure when it runs. If you build OMPI with a
>>>> --prefix of /foo, but then move it to /bar, various things may not work
>>>> (like finding help messages, etc.) unless you set the OMPI/OPAL
>>>> environment variables that tell OMPI where the files are actually
>>>> located.
>>>>
>>>> --
>>>> Jeff Squyres
>>>> jsquyres_at_[hidden]
>>>> For corporate legal information go to:
>>>> http://www.cisco.com/web/about/doing_business/legal/cri/
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>>
>>>
>
>
>