Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] USE mpi
From: Dmitry N. Mikushin (maemarcus_at_[hidden])
Date: 2011-05-07 17:35:05


> didn't find the icc compiler

Jeff, on 1.4.3 I saw the same issue, even more generally: "make
install" cannot find the compiler, if it is an alien compiler (i.e.
not the default gcc) - same situation for intel or llvm, for example.
The workaround is to specify full paths to compilers with CC=...
FC=... in ./configure params. Could it be "make install" breaks some
env paths?

- D.

2011/5/8 Jeff Squyres <jsquyres_at_[hidden]>:
> We iterated off-list -- the problem was that "sudo make install" didn't find the icc compiler, and therefore didn't complete properly.
>
> It seems that the ompi_info and mpif90 cited in this thread were from some other (broken?) OMPI installation.
>
>
>
> On May 7, 2011, at 3:01 PM, Steph Bredenhann wrote:
>
>> Sorry, I missed the 2nd statement:
>>
>>      Fortran90 bindings: yes
>> Fortran90 bindings size: small
>>       Fortran90 compiler: gfortran
>>   Fortran90 compiler abs: /usr/bin/gfortran
>>      Fortran90 profiling: yes
>>
>>
>> --
>> Steph Bredenhann
>>
>> On Sat, 2011-05-07 at 14:46 -0400, Jeff Squyres wrote:
>>> ompi_info | grep 90
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>