Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Help: HPL Problem
From: Lee Eric (openlinuxsource_at_[hidden])
Date: 2011-05-07 12:02:06


Hey mate,

I have installed glibc-devel and it seems good. I also checked the
status of the lib files they are all exist.

Eric

On Sat, May 7, 2011 at 11:11 PM, Dmitry N. Mikushin <maemarcus_at_[hidden]> wrote:
> Eric,
>
> You have a link-time error complaining about the absence of some
> libraries. At least two of them libm and libdl must be provided by
> system, not by MPI implementation. Could you locate them in
> /usr/lib64? Also it should be useful to figure out if the problem is
> global or specific to HPL: do you have any errors compiling simple
> "hello world" program with OpenMPI?
>
> - D.
>
> 2011/5/7 Lee Eric <openlinuxsource_at_[hidden]>:
>> Hi,
>>
>> I encountered following error messages when I compiled HPL.
>>
>> make[2]: Entering directory
>> `/pool/measure/hpl-2.0/testing/ptest/Linux_PII_FBLAS'
>> /pool/MPI/openmpi/bin/mpif90 -DAdd__ -DF77_INTEGER=int
>> -DStringSunStyle  -I/pool/measure/hpl-2.0/include
>> -I/pool/measure/hpl-2.0/include/Linux_PII_FBLAS
>> -I/pool/MPI/openmpi/include -fomit-frame-pointer -O3 -funroll-loops -W
>> -Wall -o /pool/measure/hpl-2.0/bin/Linux_PII_FBLAS/xhpl HPL_pddriver.o
>>        HPL_pdinfo.o           HPL_pdtest.o
>> /pool/measure/hpl-2.0/lib/Linux_PII_FBLAS/libhpl.a
>> /pool/libs/BLAS/blas_LINUX.a /pool/MPI/openmpi/lib/libmpi.so
>> /usr/bin/ld: cannot find -ldl
>> /usr/bin/ld: cannot find -lnsl
>> /usr/bin/ld: cannot find -lutil
>> /usr/bin/ld: cannot find -lm
>> /usr/bin/ld: cannot find -ldl
>> /usr/bin/ld: cannot find -lm
>> collect2: ld returned 1 exit status
>> make[2]: *** [dexe.grd] Error 1
>> make[2]: Leaving directory `/pool/measure/hpl-2.0/testing/ptest/Linux_PII_FBLAS'
>> make[1]: *** [build_tst] Error 2
>> make[1]: Leaving directory `/pool/measure/hpl-2.0'
>> make: *** [build] Error 2
>>
>> And the attachment is the make file I created. OS is Fedora 14 x86_64.
>>
>> Could anyone show me where is going wrong? Thanks.
>>
>> Eric
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>