Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] cputype (7) does not match previous archive members cputype
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-05-04 13:29:54


Did you make clean first?

configure won't clean out the prior installation, so you may be picking up stale libs.

On May 4, 2011, at 11:27 AM, Cizmas, Paul wrote:

> I added LDFLAGS=-m64, such that the command is now
>
> ./configure --prefix=/opt/openmpi1.4.3GFm64 CC=/sw/bin/gcc-fsf-4.5 CFLAGS=-m64 CXX=/sw/bin/g++-fsf-4.5 CXXFLAGS=-m64 F77=gfortran FFLAGS=-m64 FC=gfortran FCFLAGS=-m64 LDFLAGS=-m64
>
> but it did not work.
>
> It still dies when I do
>
> make all install
>
> with the errors:
>
> +++++++++++++++++++++++++++++++++++++++
> libtool: link: rm -fr .libs/libevent.a
> libtool: link: ar cru .libs/libevent.a .libs/event.o .libs/log.o .libs/evutil.o .libs/signal.o .libs/select.o
> /usr/bin/ranlib: archive member: .libs/libevent.a(signal.o) cputype (7) does not match previous archive members cputype (16777223) (all members must match)
> /usr/bin/ranlib: archive member: .libs/libevent.a(select.o) cputype (7) does not match previous archive members cputype (16777223) (all members must match)
> libtool: link: ranlib .libs/libevent.a
> ranlib: archive member: .libs/libevent.a(signal.o) cputype (7) does not match previous archive members cputype (16777223) (all members must match)
> ranlib: archive member: .libs/libevent.a(select.o) cputype (7) does not match previous archive members cputype (16777223) (all members must match)
> make[3]: *** [libevent.la] Error 1
> make[2]: *** [all-recursive] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all-recursive] Error 1
> +++++++++++++++++++++++++++++++++++++++
>
> Would it be possible that libevent.a is the problem? Does libevent.a use LDFLAGS?
>
> Thank you,
>
> Paul
> ________________________________________
> From: users-bounces_at_[hidden] [users-bounces_at_[hidden]] on behalf of Jeff Squyres [jsquyres_at_[hidden]]
> Sent: Wednesday, May 04, 2011 11:43 AM
> To: Open MPI Users
> Subject: Re: [OMPI users] cputype (7) does not match previous archive members cputype
>
> On May 4, 2011, at 12:39 PM, Paul Cizmas wrote:
>
>> ./configure --prefix=/opt/openmpi1.4.3GFm64 CC=/sw/bin/gcc-fsf-4.5 CFLAGS=-m64 CXX=/sw/bin/g++-fsf-4.5 CXXFLAGS=-m64 F77=gfortran FFLAGS=-m64 FC=gfortran FCFLAGS=-m64
>
> Oops -- sorry, you probably also need to include LDFLAGS=-m64, too (i.e., linker flags, vs. compiler flags).
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users