Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI 1.4.3 - Mac OS X 10.6.7
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-05-03 21:08:56


On May 3, 2011, at 5:29 PM, Paul Cizmas wrote:

> I have installed Gfortran GCC 4.4.4 and Absoft11.0.
>
> It appears that I have i686-apple-darwin10-gcc-4.2.1.
>
> When I run
>
> ./configure --prefix=/opt/openmpi1.4.3 F77=/Applications/Absoft11.0/bin/f77
>
> and
>
> ./configure --prefix=/opt/openmpi1.4.3GF F77=/sw/bin/gfortran
>
> in both cases I get the message:
>
> ======================================================================
> It appears that your Fortran 77 compiler is unable to link against
> object files created by your C compiler. This typically indicates
> one of a few possibilities:
>
> - A conflict between CFLAGS and FFLAGS
> - A problem with your compiler installation(s)
> - Different default build options between compilers (e.g., C
> building for 32 bit and Fortran building for 64 bit)
> - Incompatible compilers

The problem is exactly what Open MPI is telling you -- the C compiler is not compatible with the Fortran compilers that you have specified.

If you have /sw/bin/gfortran, I'm guessing you have it installed via fink...? If so, you might also have a fink-installed gcc that is compatible with that gfortran.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/