Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] BUILDING OPENMPI ON UBUNTU WITH INTEL 11.1
From: Steph Bredenhann (support_at_[hidden])
Date: 2011-05-03 13:36:22


Dear Sir/Madam

I want to build openmpi for use with INTEL compilers (version 11.1) on my Ubuntu
10.10 x64 system. I am using the guidelines from
http://software.intel.com/en-us/articles/performance-tools-for-software-developers-building-open-mpi-with-the-intel-compilers/
and specifically the following instructions:

./configure --prefix=/usr/local CC=icc CXX=icpc F77=ifort FC=ifort
... output of configure ...
make all install
... output of build and installation ...

The result is shown below. As can be seen it was unsuccessful. I'll appreciate
some guidance here as I am nearing the deadline for a project that is part of
my research for my PhD.

Thanks in advance.

steph_at_sjb-linux:/src/openmpi-1.4.3$ ./configure --prefix=/opt/openmpi-1.4.3
CC=icc CXX=icpc F77=ifort FC=ifort
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
: command not foundconfig/missing: line 3:
: command not foundconfig/missing: line 5:
: command not foundconfig/missing: line 9:
: command not foundconfig/missing: line 14:
: command not foundconfig/missing: line 19:
: command not foundconfig/missing: line 24:
: command not foundconfig/missing: line 29:
/src/openmpi-1.4.3/config/missing: line 49: syntax error near unexpected token
`'n
'src/openmpi-1.4.3/config/missing: line 49: `case $1 in
configure: WARNING: `missing' script is too old or missing
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar

============================================================================
== Configuring Open MPI
============================================================================

*** Checking versions
: integer expression expected 3
: integer expression expected 0
.4ecking Open MPI version... 1
checking Open MPI release date... Oct 05, 2010
checking Open MPI Subversion repository version... r23834
: integer expression expected 3
: integer expression expected 0
.4ecking Open Run-Time Environment version... 1
checking Open Run-Time Environment release date... Oct 05, 2010
checking Open Run-Time Environment Subversion repository version... r23834
: integer expression expected 3
: integer expression expected 0
.4ecking Open Portable Access Layer version... 1
checking Open Portable Access Layer release date... Oct 05, 2010
checking Open Portable Access Layer Subversion repository version... r23834
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found
: command not found

*** Initialization, setup
configure: builddir: /src/openmpi-1.4.3
configure: srcdir: /src/openmpi-1.4.3
configure: error: cannot run /bin/sh config/config.sub
steph_at_sjb-linux:/src/openmpi-1.4.3$ make all install
make: *** No rule to make target `all'. Stop.
steph_at_sjb-linux:/src/openmpi-1.4.3$ make install
make: *** No rule to make target `install'. Stop.
steph_at_sjb-linux:/src/openmpi-1.4.3$

Regards

Steph Bredenhann

-- 
This message was sent by Adept Internet's webmail. 
http://www.adept.co.za/