Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Need help buiding OpenMPI with Intel v12.0 compilers on Linux
From: Tru Huynh (tru_at_[hidden])
Date: 2011-04-27 18:57:20


On Thu, Apr 28, 2011 at 12:46:27AM +0200, Tru Huynh wrote:
> On Thu, Apr 21, 2011 at 06:35:16PM -0400, Jeff Squyres wrote:
> > It's normal and expected for there to be lots of errors in config.log.
> >
> > There's a bunch of tests in configure that are designed to succeed on some systems and fail on others.
> >
> > So don't read anything into the failures that you see in config.log -- unless configure itself fails. Then we generally go look at the *last* failures in config.log to start backtracking to figure out what went wrong.
> >
>
> for what's worth this works fine for me CentOS 5 x86_64:
> ./configure --prefix=/c5/shared/openmpi/1.4.3/sge/6.2u4/intel/12.2011.3.174 --with-sge CC=icc FC=ifort CXX=icpc F77=ifort && make && make check && make install
>
The above was with:
Intel(R) C Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 12.0 Build 20110309
Copyright (C) 1985-2011 Intel Corporation. All rights reserved.

I have just retried with the initial XE version:
Intel(R) C Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 12.0 Build 20101006
Copyright (C) 1985-2010 Intel Corporation. All rights reserved.

builds and passes the check too.

my 2 cents

Tru

-- 
Dr Tru Huynh          | http://www.pasteur.fr/recherche/unites/Binfs/
mailto:tru_at_[hidden] | tel/fax +33 1 45 68 87 37/19
Institut Pasteur, 25-28 rue du Docteur Roux, 75724 Paris CEDEX 15 France