Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] RES: RES: RES: Error with ARM target
From: Fernando Dutra Fagundes Macedo (fmacedo_at_[hidden])
Date: 2011-04-25 10:00:05


I tried 1.5.2 and 1.5.3.

-----Mensagem original-----
De: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] Em nome de Barrett, Brian W
Enviada em: segunda-feira, 25 de abril de 2011 10:53
Para: Open MPI Users
Assunto: Re: [OMPI users] RES: RES: Error with ARM target

--host is the correct option, but the host string "arm" is not valid; it needs to be a proper triple, something like "x86_64-unknown-linux-gnu".
Either way, ARM was not a supported platform in the 1.4.x release; the earliest version of Open MPI to support the ARM platform was 1.5.2.

Brian

On 4/25/11 7:46 AM, "Ralph Castain" <rhc_at_[hidden]> wrote:

>I think you've reversed the role of host and target then. "host" is the
>machine type you are compiling on, and "target" is the machine you are
>compiling for.
>
>There used to be a wiki page on cross-compiling OMPI, but I couldn't
>locate it this morning - I'm sure it's still there, but it is hard to
>find. Try searching the OMPI web site for info.
>
>
>On Apr 25, 2011, at 5:09 AM, Fernando Dutra Fagundes Macedo wrote:
>
>> I'm trying to cross-compile.
>>
>> -----Mensagem original-----
>> De: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] Em
>>nome de Ralph Castain Enviada em: sábado, 23 de abril de 2011 17:21
>> Para: Open MPI Users
>> Assunto: Re: [OMPI users] RES: Error with ARM target
>>
>> Don't give it a host argument - unless you are trying to
>>cross-compile, it should figure it out for itself
>>
>>
>> On Apr 23, 2011, at 1:25 PM, Fernando Dutra Fagundes Macedo wrote:
>>
>>> Correcting:
>>>
>>> I tried 1.5.2 and 1.5.3.
>>>
>>>
>>> -----Mensagem original-----
>>> De: users-bounces_at_[hidden] em nome de Fernando Dutra Fagundes
>>>Macedo
>>> Enviada: sáb 23/4/2011 16:16
>>> Para: users_at_[hidden]
>>> Assunto: [OMPI users] Error with ARM target
>>>
>>> Hi,
>>>
>>> I am trying to use Open MPI on a Friendly ARM board, but I can't
>>>compile it to ARM target. I'm trying to configure the package this way:
>>>
>>> ./configure -host="arm"
>>>
>>> What can I do to make it work?
>>>
>>> More information:
>>>
>>> Error: "configure: error: No atomic primitives available for
>>>arm-unknown-none"
>>> Version: 1.4.2 and 1.4.3
>>>
>>> Thanks in advance,
>>> Fernando Macedo
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>> <winmail.dat>_______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>_______________________________________________
>users mailing list
>users_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>

--
  Brian W. Barrett
  Dept. 1423: Scalable System Software
  Sandia National Laboratories
_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users