Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Removing Portals BTLs
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-04-21 14:03:26


Sure - instead of what you did, just add --without-portals to your original configure. The exact option depends on what portals you have installed.

Here is the relevant part of the "./configure -h" output:

  --with-portals=DIR Specify the installation directory of PORTALS
  --with-portals-libs=LIBS
                          Libraries to link with for portals
  --with-portals4(=DIR) Build Portals4 support, optionally adding
                          DIR/include, DIR/lib, and DIR/lib64 to the search
                          path for headers and libraries
  --with-portals4-libdir=DIR
                          Search for Portals4 libraries in DIR

Just do --without-portals or --without-portals4 (you don't need the matching libdir option), whichever matches what you have.

On Apr 21, 2011, at 11:34 AM, Paul Monday wrote:

> Hi,
>
> I am trying to get rid of the following error message when I use mpirun.
>
> mca: base: component_find: "mca_ess_portals_utcp" does not appear to be a valid
> ess MCA dynamic component (ignored):
> /usr/local/lib/openmpi/mca_ess_portals_utcp.so: undefined symbol:
> mca_ess_portals_utcp_component
>
> I am trying to remove the portals components altogether...here's why:
>
> When I originally built openmpi, I used a simple configuration string:
> ./configure --with-threads=posix --enable-mpi-threads --with-openib=/usr
> --with-openib-libdir=/usr/lib64 --disable-mpi-cxx
>
> This gives me an error while the make is running, most likely a problem with my
> Portals installation. So, I just want to skip Portals BTLs.
> /usr/bin/ld: /usr/local/lib/libp3api.a(libp3api_a-acl.o): relocation
> R_X86_64_32S against `p3_api_process' can not be used when making a shared
> object; recompile with -fPIC
> /usr/local/lib/libp3api.a: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> make[2]: *** [libmpi.la] Error 1
> make[2]: Leaving directory `/mnt/shared/apps/openmpi-1.4.3/ompi'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/mnt/shared/apps/openmpi-1.4.3/ompi'
> make: *** [all-recursive] Error 1
>
> So I changed the configuration to:
> ./configure --with-threads=posix --enable-mpi-threads --with-openib=/usr
> --with-openib-libdir=/usr/lib64 --disable-mpi-cxx
> --enable-mca-no-build=btl-portals,ess-portals_utcp,common-portals,mtl-portals
>
> This allowed OpenMPI to build, but then I receive the runtime error above. Is
> there a way to stop the Portals pieces from even trying to build and run?
>
> Paul Monday
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users