Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] using openib and psm together
From: Dave Love (d.love_at_[hidden])
Date: 2011-04-21 06:01:38


We have an installation with both Mellanox and Qlogic IB adaptors (in
distinct islands), so I built open-mpi 1.4.3 with openib and psm
support.

Now I've just read this in the OFED source, but I can't see any relevant
issue in the open-mpi tracker:

  OpenMPI support
  ---------------
  It is recommended to use the OpenMPI v1.5 development branch. Prior versions
  of OpenMPI have an issue with support PSM network transports mixed with standard
  Verbs transport (BTL openib). This prevents an OpenMPI installation with
  network modules available for PSM and Verbs to work correctly on nodes with
  no QLogic IB hardware. This has been fixed in the latest development branch
  allowing a single OpenMPI installation to target IB hardware via PSM or Verbs
  as well as alternate transports seamlessly.

Do I definitely need 1.5 (and is 1.5.3 good enough?) to have openib and
psm working correctly? Also what are the symptoms of it not working
correctly?