Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem compiling OpenMPI on Ubuntu 11.04
From: Tim Prince (n8tm_at_[hidden])
Date: 2011-04-19 17:03:49


  On 04/19/2011 01:24 PM, Sergiy Bubin wrote:
> /usr/include/c++/4.5/iomanip(64): error: expected an expression
> { return { __mask }; }
> ^
> /usr/include/c++/4.5/iomanip(94): error: expected an expression
> { return { __mask }; }
> ^
> /usr/include/c++/4.5/iomanip(125): error: expected an expression
> { return { __base }; }
> ^
> /usr/include/c++/4.5/iomanip(193): error: expected an expression
> { return { __n }; }
> ^
> /usr/include/c++/4.5/iomanip(223): error: expected an expression
> { return { __n }; }
> ^
> /usr/include/c++/4.5/iomanip(163): error: expected an expression
> { return { __c }; }
> ^
>
If you're using icpc, this seeming incompatibility between icpc and g++
4.5 has been discussed on the icpc forum
http://software.intel.com/en-us/forums/showthread.php?t=78677&wapkw=%28iomanip%29
where you should see that you must take care to set option -std=c++0x
when using current <iomanip> under icpc, as it is treated as a c++0x
feature. You might try adding the option to the CXXFLAGS or whatever
they are called in openmpi build (or to the icpc.cfg in your icpc
installation).

-- 
Tim Prince