Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Need help buiding OpenMPI with Intel v12.0 compilers on Linux
From: Gus Correa (gus_at_[hidden])
Date: 2011-04-19 15:30:41


Hi Scott

Is it possible that the Intel compiler environment is not set?

Just in case, did you source the right Intel scripts to setup
the icc, icpc, and ifort environment?
Something like this (for a 64-bit machine):

source /opt/intel/composerxe-2011.1.107/bin/compilervars.csh intel64

and perhaps a similar command for icc/icpc.
Check the compiler documentation for details.

I only have ifort 12.0 in one of our machines here, no icc or icpc.
However, the OS is CentOS 5.4 64-bit,
and I compiled OpenMPI 1.4.3 there with gcc, g++ and ifort
without any problem.
I would guess you can do it with icc, icpc and ifort too.

Another possibility is some name mangling issue.
Maybe the leading double underscore on the C symbols?

I hope this helps,
Gus Correa

Ormiston, Scott J. wrote:
> I am trying to build OpenMPI with the Intel v12.0 compiler on Linux
> (Centos 5).
> I configured using:
>
> ./configure --prefix=/home/mecfd/common/sw/openmpi-intel/ \
> CC=icc CXX=icpc F77=ifort FC=ifort
>
> but when it was compiling it died with the following errors at the end:
>
> ...
> Making all in tools/wrappers
> make[2]: Entering directory
> `/home/mecfd/common/sw/openmpi-1.4.3/opal/tools/wrappers'
> depbase=`echo opal_wrapper.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
> icc "-DEXEEXT=\"\"" -I. -I../../../opal/include
> -I../../../orte/include -I../../../ompi/include
> -I../../../opal/mca/paffinity/linux/plpa/src/libplpa -I../../.. -O3
> -DNDEBUG -finline-functions -fno-strict-aliasing -restrict -pthread
> -fvisibility=hidden -MT opal_wrapper.o -MD -MP -MF $depbase.Tpo -c -o
> opal_wrapper.o opal_wrapper.c &&\
> mv -f $depbase.Tpo $depbase.Po
> /bin/sh ../../../libtool --tag=CC --mode=link icc -O3 -DNDEBUG
> -finline-functions -fno-strict-aliasing -restrict -pthread
> -fvisibility=hidden -export-dynamic -o opal_wrapper opal_wrapper.o
> ../../../opal/libopen-pal.la -lnsl -lutil
> libtool: link: icc -O3 -DNDEBUG -finline-functions -fno-strict-aliasing
> -restrict -pthread -fvisibility=hidden -o .libs/opal_wrapper
> opal_wrapper.o -Wl,--export-dynamic ../../../opal/.libs/libopen-pal.so
> -lpthread -ldl -lnsl -lutil -pthread -Wl,-rpath
> -Wl,/home/mecfd/common/sw/openmpi-intel/lib
> /usr/local/Intel/composerxe-2011.2.137/compiler/lib/intel64/libimf.so:
> warning: warning: feupdateenv is not implemented and will always fail
> ../../../opal/.libs/libopen-pal.so: undefined reference to `__c_mcopy1'
> ../../../opal/.libs/libopen-pal.so: undefined reference to `__c_bzero'
> make[2]: *** [opal_wrapper] Error 1
> make[2]: Leaving directory
> `/home/mecfd/common/sw/openmpi-1.4.3/opal/tools/wrappers'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/mecfd/common/sw/openmpi-1.4.3/opal'
> make: *** [all-recursive] Error 1
>
> Does anyone know how to avoid this error?
>
> Scott Ormiston
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users