Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mca_oob_tcp_msg_recv: readv failed:Unknown error (10054)
From: hi (hiralsmaillist_at_[hidden])
Date: 2011-04-19 09:19:34


On WINDOWS platform, I am observing following error when executing
"mpirun blacs_hello_example.exe" (example program to test BLACS taken
from http://www.netlib.org/blacs/BLACS/Examples.html#HELLO)...

C:\blacs_examples> mpirun blacs_hello_example.exe
 calling blacs_pinfo()...
forrtl: severe (157): Program Exception - access violation
Image PC Routine Line Source
libmpid.dll 6A8E2DC5 Unknown Unknown Unknown
libmpid.dll 6A8E2C31 Unknown Unknown Unknown
blacs_ex01.exe 00402357 Unknown Unknown Unknown
libifcorert.dll 1002A1C1 Unknown Unknown Unknown
[myhost1:15340] [[30379,0],0]-[[30379,1],0] mca_oob_tcp_msg_recv:
readv failed:Unknown error (10054)
--------------------------------------------------------------------------
mpirun.exe has exited due to process rank 0 with PID 528 on node
vibgyor exiting improperly. There are two reasons this could occur:

1. this process did not call "init" before exiting, but others in the
job did. This can cause a job to hang indefinitely while it waits for
all processes to call "init". By rule, if one process calls "init",
then ALL processes must call "init" prior to termination.

2. this process called "init", but exited without calling "finalize".
By rule, all processes that call "init" MUST call "finalize" prior to
exiting or it will be considered an "abnormal termination"

This may have caused other processes in the application to be
terminated by signals sent by mpirun.exe (as reported here).
--------------------------------------------------------------------------

Environment:
OS: Windows 7 64-bit
Compilers: Visual Studio 2008 32bit and Intel ifort 32bit
OpenMPI: OpenMPI-1.5.3 pre-built libraries and also with
OpenMPI-1.5.2. locally built libraries
BLACS: pre-built libraries taken from
http://icl.cs.utk.edu/lapack-for-windows/scalapack/index.html#librairies

Any idea on how to resolve this???

Thank you in advance.
-Hiral