Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] "Value out of bounds in file" error
From: hi (hiralsmaillist_at_[hidden])
Date: 2011-04-13 07:47:12


Hi Rainer,

When executing "mpirun blacs_hello_example.exe" (reference:
http://www.netlib.org/blacs/BLACS/Examples.html#HELLO), I am now getting
folloing error...

<<<<<<
C:\blacs_examples>mpirun blacs_hello_example.exe
forrtl: severe (157): Program Exception - access violation
Image PC Routine Line Source
libmpid.dll 63472DC5 Unknown Unknown Unknown
libmpid.dll 63472C31 Unknown Unknown Unknown
blacs_ex01.exe 0040418A Unknown Unknown Unknown
blacs_ex01.exe 00401034 Unknown Unknown Unknown
blacs_ex01.exe 00401F53 Unknown Unknown Unknown
blacs_ex01.exe 0040182A Unknown Unknown Unknown
kernel32.dll 75E23677 Unknown Unknown Unknown
ntdll.dll 77049F02 Unknown Unknown Unknown
ntdll.dll 77049ED5 Unknown Unknown Unknown
[vibgyor:08548] [[27683,0],0]-[[27683,1],0] mca_oob_tcp_msg_recv: readv
failed: Unknown error (10054)
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 480 on
node vibgyor exiting improperly. There are two reasons this could occur:
1. this process did not call "init" before exiting, but others in
the job did. This can cause a job to hang indefinitely while it waits
for all processes to call "init". By rule, if one process calls "init",
then ALL processes must call "init" prior to termination.
2. this process called "init", but exited without calling "finalize".
By rule, all processes that call "init" MUST call "finalize" prior to
exiting or it will be considered an "abnormal termination"
This may have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).
--------------------------------------------------------------------------
>>>>>>

Any idea on this???

Thank you.
-Hiral
On Wed, Apr 13, 2011 at 11:45 AM, hi <hiralsmaillist_at_[hidden]> wrote:

> Hi Rainer,
>
> Thanks for acknowledgment.
>
> > You may want to port/compile BLACS from netlib yourselve, see here:
> > http://icl.cs.utk.edu/lapack-for-windows/VisualStudio_install.html
>
> With that I am seeing compilation errors as reported in...
> http://icl.cs.utk.edu/lapack-forum/viewtopic.php?f=12&t=2354
>
> Please comment on this, if you any idea.
>
> Thank you.
> -Hiral
> On Wed, Apr 13, 2011 at 1:37 AM, Rainer Keller <keller_at_[hidden]> wrote:
>
>> Hiral,
>>
>> On Monday 11 April 2011 15:04:19 hi wrote:
>> > Is it the case that I am combining mkl_intelmpi with locally built
>> openmpi
>> > and hence this problem???
>> Yes, as You mention yourselve here ,-]
>>
>> > ...
>> > Files (x86)\Intel\Compiler\11.1\065\mkl/ia32/lib" mkl_blacs_intelmpi.lib
>> > mkl_core.lib mkl_core_dll.lib /LIBPATH:"C:/Program Files
>>
>> MKL includes the BLACS interface -- however, MKL is built against
>> Intel-MPI:
>> under Linux-based MKL, there exist the static libraries
>> libmkl_blacs_intelmpi_*lp64.a, libmkl_blacs_sgimpt_*lp64.a and
>> libmkl_blacs_openmpi_*lp64.a.
>>
>> The corresponding libraries do not exist under your windows installation.
>>
>> You may want to port/compile BLACS from netlib yourselve, see here:
>> http://icl.cs.utk.edu/lapack-for-windows/VisualStudio_install.html
>>
>> Hope this helps?
>>
>> Best regards,
>> Rainer
>> --
>> ----------------------------------------------------------------
>> Dr.-Ing. Rainer Keller http://www.hlrs.de/people/keller
>> HLRS Tel: ++49 (0)711-685 6 5858
>> Nobelstrasse 19 Fax: ++49 (0)711-685 6 5832
>> 70550 Stuttgart email: keller_at_[hidden]
>> Germany AIM/Skype:rusraink
>>
>
>