Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] Problem with setting up openmpi-1.4.3
From: amosleff_at_[hidden]
Date: 2011-04-12 19:17:23


Hi,
         I am embarrassed! I submitted a note to the users on setting up
openmpi-1.4.3 using SUSE-11.3 under Linux and received several replies. I
wanted to transfer them but they disappeared for no apparent reason. I
hope that those that sent me messages will be kind enough to repeat them and
perhaps more users will add their ideas.
         I am running SUSE-11.3 under VMware-7.1 and downloaded the openmpi
program. The "configuration..." step went fine but the "make all install"
step hung up as shown below.

mpragma_c.Tpo -c -o ompragma_c.o ompragma_c.cc
/usr/include/c++/4.5/iomanip(64): error: expected an expression
    { return { __mask }; }
             ^

/usr/include/c++/4.5/iomanip(94): error: expected an expression
    { return { __mask }; }
             ^

/usr/include/c++/4.5/iomanip(125): error: expected an expression
    { return { __base }; }
             ^

/usr/include/c++/4.5/iomanip(193): error: expected an expression
    { return { __n }; }
             ^

/usr/include/c++/4.5/iomanip(223): error: expected an expression
    { return { __n }; }
             ^

/usr/include/c++/4.5/iomanip(163): error: expected an expression
      { return { __c }; }
               ^

compilation aborted for ompragma_c.cc (code 2)
make[7]: *** [ompragma_c.o] Error 2
make[7]: Leaving directory
`/home/amos/Downloads/openmpi-1.4.3/ompi/contrib/vt/vt/tools/opari/tool'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory
`/home/amos/Downloads/openmpi-1.4.3/ompi/contrib/vt/vt/tools/opari'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory
`/home/amos/Downloads/openmpi-1.4.3/ompi/contrib/vt/vt/tools'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
`/home/amos/Downloads/openmpi-1.4.3/ompi/contrib/vt/vt'
make[3]: *** [all] Error 2
make[3]: Leaving directory
`/home/amos/Downloads/openmpi-1.4.3/ompi/contrib/vt/vt'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/home/amos/Downloads/openmpi-1.4.3/ompi/contrib/vt'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/amos/Downloads/openmpi-1.4.3/ompi'
make: *** [all-recursive] Error 1

I have looked at the program but don't see anything obviously wrong.
Hopefully somebody who is familiar with the program will see what the
problem is. Any help would be much appreciated.

Amos Leffler