Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] "Value out of bounds in file" error
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-04-12 06:06:52


Can you provide more information?

Where / when exactly does this error occur? E.g., does it happen during MPI_INIT, or is it later in the application?

Are you able to run any MPI codes at all, such as the example "hello world" or "ring" programs? Are you able to run non-MPI applications at all, such as "hostname" (or whatever the equivalent is in Windows)?

Please send all the information listed here:

    http://www.open-mpi.org/community/help/

On Apr 11, 2011, at 9:04 AM, hi wrote:

> Hi,
>
> For the attached test program (reference: http://www.netlib.org/blacs/BLACS/Examples.html#HELLO), I am observing following message and binary halts...
>
> [<machine_name>:03864] [[16991,0],0] ORTE_ERROR_LOG: Value out of bounds in file ..\..\orte\mca\oob\tcp\oob_tcp.c at line 1193
>
>
> *Command used to compile is as follow:
> 1) ifort blacs_ex01.f -c -I"C:\Program Files (x86)\Intel\Compiler\11.1\065\mkl/include"
>
> 2) link /SUBSYSTEM:CONSOLE -NODEFAULTLIB /INCREMENTAL:NO /MAP /MAPINFO:EXPORTS /DEBUG -opt:ref,icf /out:blacs_ex01.exe blacs_ex01.obj /LIBPATH:"C:/Program Files (x86)/Intel/Compiler/11.1/065\\Lib\ia32" libirc.lib libifcorert.lib /LIBPATH:"C:\Program Files (x86)\Intel\Compiler\11.1\065\lib\ia32" ifqwin.lib /LIBPATH:"C:\Program Files (x86)\Intel\Compiler\11.1\065\mkl/ia32/lib" mkl_blacs_intelmpi.lib mkl_core.lib mkl_core_dll.lib /LIBPATH:"C:/Program Files (x86)/Intel/Compiler/11.1/065/mkl\\ia32\\lib" mkl_lapack95.lib mkl_core_dll.lib mkl_intel_c_dll.lib mkl_intel_thread_dll.lib /LIBPATH:"C:/Program Files (x86)/Intel/Compiler/11.1/065/mkl/ia32/lib/" mkl_scalapack_core.lib mkl_blacs_dll.lib /LIBPATH:"C:\openmpi-1.5.2\installed_vs2008\lib" libmpi_f77d.lib libmpid.lib libopen-pald.lib libopen-rted.lib /LIBPATH:"C:\Program Files\Microsoft SDKs\Windows\v6.1\\\Lib" /LIBPATH:"C:/Program Files (x86)/Microsoft Visual Studio 9.0/VC\\Lib" msvcrt.lib msvcprt.lib kernel32.lib
>
> * Environment:
> OS: Windows 7 (64-bit)
> Compiler: cl.exe (32-bit) and ifort (32-bit)
> MPI: openmpi-1.5.2 (local build)
>
> Is it the case that I am combining mkl_intelmpi with locally built openmpi and hence this problem???
>
> Thank you in advance.
> -Hiral
> <blacs_ex01.f>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/