Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] problems with the -xterm option
From: jody (jody.xha_at_[hidden])
Date: 2011-04-06 11:19:15


Hi Ralph
No, after the above error message mpirun has exited.

But i also noticed that it is to ssh into squid_0 and open a xterm there:

  jody_at_chefli ~/share/neander $ ssh -Y squid_0
  Last login: Wed Apr 6 17:14:02 CEST 2011 from chefli.uzh.ch on pts/0
  jody_at_squid_0 ~ $ xterm
  xterm Xt error: Can't open display:
  xterm: DISPLAY is not set
  jody_at_squid_0 ~ $ export DISPLAY=130.60.126.74:0.0
  jody_at_squid_0 ~ $ xterm
  xterm Xt error: Can't open display: 130.60.126.74:0.0
  jody_at_squid_0 ~ $ export DISPLAY=chefli.uzh.ch:0.0
  jody_at_squid_0 ~ $ xterm
  xterm Xt error: Can't open display: chefli.uzh.ch:0.0
  jody_at_squid_0 ~ $ exit
  logout

same thing with ssh -X, but here i get the same warning/error message
as with mpirun:

  jody_at_chefli ~/share/neander $ ssh -X squid_0
  Warning: untrusted X11 forwarding setup failed: xauth key data not generated
  Warning: No xauth data; using fake authentication data for X11 forwarding.
  Last login: Wed Apr 6 17:12:31 CEST 2011 from chefli.uzh.ch on ssh

So perhaps the whole problem is linked to that xauth-thing.
Do you have a suggestion how this can be solved?

Thank You
  Jody

On Wed, Apr 6, 2011 at 4:41 PM, Ralph Castain <rhc_at_[hidden]> wrote:
> If I read your error messages correctly, it looks like mpirun is crashing - the daemon is complaining that it lost the socket connection back to mpirun, and hence will abort.
>
> Are you seeing mpirun still alive?
>
>
> On Apr 5, 2011, at 4:46 AM, jody wrote:
>
>> Hi
>>
>> On my workstation and  the cluster i set up OpenMPI (v 1.4.2) so that
>> it works in "text-mode":
>>  $ mpirun -np 4  -x DISPLAY -host squid_0   printenv | grep WORLD_RANK
>>  OMPI_COMM_WORLD_RANK=0
>>  OMPI_COMM_WORLD_RANK=1
>>  OMPI_COMM_WORLD_RANK=2
>>  OMPI_COMM_WORLD_RANK=3
>>
>> but when i use  the -xterm option to mpirun, it doesn't work
>>
>> $ mpirun -np 4  -x DISPLAY -host squid_0 -xterm 1,2  printenv | grep WORLD_RANK
>>  Warning: untrusted X11 forwarding setup failed: xauth key data not generated
>>  Warning: No xauth data; using fake authentication data for X11 forwarding.
>>  OMPI_COMM_WORLD_RANK=0
>>  [squid_0:05266] [[55607,0],1]->[[55607,0],0]
>> mca_oob_tcp_msg_send_handler: writev failed: Bad file descriptor (9)
>> [sd = 8]
>>  [squid_0:05266] [[55607,0],1] routed:binomial: Connection to
>> lifeline [[55607,0],0] lost
>>  /usr/bin/xterm Xt error: Can't open display: chefli.uzh.ch:0.0
>>  /usr/bin/xterm Xt error: Can't open display: chefli.uzh.ch:0.0
>>
>> (strange: somebody wrote his message to the console)
>>
>> No matter whether i set the DISPLAY variable to the full hostname of
>> the workstation,
>> to the IP-Adress of the workstation or simply to ":0.0", it doesn't work
>>
>> But i do have xauth data (as far as i know):
>> On the remote (squid_0):
>>  jody_at_squid_0 ~ $ xauth list
>>  chefli/unix:10  MIT-MAGIC-COOKIE-1  5293e179bc7b2036d87cbcdf14891d0c
>>  chefli/unix:0  MIT-MAGIC-COOKIE-1  146c7f438fab79deb8a8a7df242b6f4b
>>  chefli.uzh.ch:0  MIT-MAGIC-COOKIE-1  146c7f438fab79deb8a8a7df242b6f4b
>>
>> on the workstation:
>>  $ xauth list
>>  chefli/unix:10  MIT-MAGIC-COOKIE-1  5293e179bc7b2036d87cbcdf14891d0c
>>  chefli/unix:0  MIT-MAGIC-COOKIE-1  146c7f438fab79deb8a8a7df242b6f4b
>>  localhost.localdomain/unix:0  MIT-MAGIC-COOKIE-1
>> 146c7f438fab79deb8a8a7df242b6f4b
>>  chefli.uzh.ch/unix:0  MIT-MAGIC-COOKIE-1  146c7f438fab79deb8a8a7df242b6f4b
>>
>> In sshd_config on the workstation i have 'X11Forwarding yes'
>> I have also done
>>   xhost + squid_0
>> on the workstation.
>>
>>
>> How can i get the -xterm option running?
>>
>> Thank You
>>  Jody
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>