Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] problems with the -xterm option
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-04-06 10:41:43


If I read your error messages correctly, it looks like mpirun is crashing - the daemon is complaining that it lost the socket connection back to mpirun, and hence will abort.

Are you seeing mpirun still alive?

On Apr 5, 2011, at 4:46 AM, jody wrote:

> Hi
>
> On my workstation and the cluster i set up OpenMPI (v 1.4.2) so that
> it works in "text-mode":
> $ mpirun -np 4 -x DISPLAY -host squid_0 printenv | grep WORLD_RANK
> OMPI_COMM_WORLD_RANK=0
> OMPI_COMM_WORLD_RANK=1
> OMPI_COMM_WORLD_RANK=2
> OMPI_COMM_WORLD_RANK=3
>
> but when i use the -xterm option to mpirun, it doesn't work
>
> $ mpirun -np 4 -x DISPLAY -host squid_0 -xterm 1,2 printenv | grep WORLD_RANK
> Warning: untrusted X11 forwarding setup failed: xauth key data not generated
> Warning: No xauth data; using fake authentication data for X11 forwarding.
> OMPI_COMM_WORLD_RANK=0
> [squid_0:05266] [[55607,0],1]->[[55607,0],0]
> mca_oob_tcp_msg_send_handler: writev failed: Bad file descriptor (9)
> [sd = 8]
> [squid_0:05266] [[55607,0],1] routed:binomial: Connection to
> lifeline [[55607,0],0] lost
> /usr/bin/xterm Xt error: Can't open display: chefli.uzh.ch:0.0
> /usr/bin/xterm Xt error: Can't open display: chefli.uzh.ch:0.0
>
> (strange: somebody wrote his message to the console)
>
> No matter whether i set the DISPLAY variable to the full hostname of
> the workstation,
> to the IP-Adress of the workstation or simply to ":0.0", it doesn't work
>
> But i do have xauth data (as far as i know):
> On the remote (squid_0):
> jody_at_squid_0 ~ $ xauth list
> chefli/unix:10 MIT-MAGIC-COOKIE-1 5293e179bc7b2036d87cbcdf14891d0c
> chefli/unix:0 MIT-MAGIC-COOKIE-1 146c7f438fab79deb8a8a7df242b6f4b
> chefli.uzh.ch:0 MIT-MAGIC-COOKIE-1 146c7f438fab79deb8a8a7df242b6f4b
>
> on the workstation:
> $ xauth list
> chefli/unix:10 MIT-MAGIC-COOKIE-1 5293e179bc7b2036d87cbcdf14891d0c
> chefli/unix:0 MIT-MAGIC-COOKIE-1 146c7f438fab79deb8a8a7df242b6f4b
> localhost.localdomain/unix:0 MIT-MAGIC-COOKIE-1
> 146c7f438fab79deb8a8a7df242b6f4b
> chefli.uzh.ch/unix:0 MIT-MAGIC-COOKIE-1 146c7f438fab79deb8a8a7df242b6f4b
>
> In sshd_config on the workstation i have 'X11Forwarding yes'
> I have also done
> xhost + squid_0
> on the workstation.
>
>
> How can i get the -xterm option running?
>
> Thank You
> Jody
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users