Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] orte-odls-default:execv-error
From: SLIM H.A. (h.a.slim_at_[hidden])
Date: 2011-04-05 09:57:02


Hi Reuti

1.4.2 is still in the same location and I also built 1.4.3 anew. It
appeared the lustre and ib where not playing along and it is working
now.

Thanks

henk

> -----Original Message-----
> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
On
> Behalf Of Reuti
> Sent: 05 April 2011 11:23
> To: Open MPI Users
> Subject: Re: [OMPI users] orte-odls-default:execv-error
>
> Am 05.04.2011 um 11:11 schrieb SLIM H.A.:
>
> > After an upgrade of our system I receive the following error message
> > (openmpi 1.4.2 with gridengine):
>
> Did you move openmpi 1.4.2 to a new (i.e. different) location?
>
> -- Reuti
>
>
> >> quote
> >
---------------------------------------------------------------------
> ---
> > --
> > Sorry! You were supposed to get help about:
> > orte-odls-default:execv-error
> > But I couldn't open the help file:
> > ...path/1.4.2/share/openmpi/help-odls-default.txt: Cannot send
> after
> > transport endpoint shut
> > down. Sorry!
> >> end quote
> >
> > and this is this is the section in the text file
> > ...path/1.4.2/share/openmpi/help-odls-default.txt that refers to
> > orte-odls-default:execv-error
> >
> >
> >> quote
> > [orte-odls-default:execv-error]
> > Could not execute the executable "%s": %s
> >
> > This could mean that your PATH or executable name is wrong, or that
> you
> > do not
> > have the necessary permissions. Please ensure that the executable
is
> > able to be
> > found and executed."
> >> end quote
> >
> > Does the execv-error mean that the file
> > ...path/1.4.2/share/openmpi/help-odls-default.txt was not accessible
> or
> > is there a different reason?
> >
> > The error message continues with
> >
> >> quote
> >
---------------------------------------------------------------------
> ---
> > --
> > [cn004:00591] mca: base: component_find: unable to open
> > ...path/1.4.2/lib/openmpi/mca_grpcomm_basic: file not found
(ignored)
> > [cn004:00586] mca: base: component_find: unable to open
> > ...path/1.4.2/lib/openmpi/mca_notifier_syslog: file not found
> (ignored)
> > [cn004:00585] mca: base: component_find: unable to open
> > ...path/1.4.2/lib/openmpi/mca_notifier_syslog: file not found
> (ignored)
> >
---------------------------------------------------------------------
> ---
> > --
> > Sorry! You were supposed to get help about:
> > find-available:none-found
> > But I couldn't open the help file:
> > ...path/1.4.2/share/openmpi/help-mca-base.txt: Cannot send after
> > transport endpoint shutdown
> > . Sorry!
> >
---------------------------------------------------------------------
> ---
> > --
> > [cn004:00586] PML ob1 cannot be selected
> >> end quote
> >
> > but there are .so and .la libraries in the directory
> > ...path/1.4.2/lib/openmpi
> > Are those the ones not found?
> >
> > Thanks
> >
> > Henk
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users