Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpi problems,
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-04-04 16:02:25


Well, where is libfui located? Is that location in your ld path? Is the lib present on all nodes in your hostfile?

On Apr 4, 2011, at 1:58 PM, Nehemiah Dacres wrote:

> [jian_at_therock ~]$ echo $LD_LIBRARY_PATH
> /opt/sun/sunstudio12.1/lib:/opt/vtk/lib:/opt/gridengine/lib/lx26-amd64:/opt/gridengine/lib/lx26-amd64:/home/jian/.crlibs:/home/jian/.crlibs32
> [jian_at_therock ~]$ /opt/SUNWhpc/HPC8.2.1c/sun/bin/mpirun -np 4 -hostfile list ring2
> ring2: error while loading shared libraries: libfui.so.1: cannot open shared object file: No such file or directory
> ring2: error while loading shared libraries: libfui.so.1: cannot open shared object file: No such file or directory
> ring2: error while loading shared libraries: libfui.so.1: cannot open shared object file: No such file or directory
> mpirun: killing job...
>
> --------------------------------------------------------------------------
> mpirun noticed that process rank 1 with PID 31763 on node compute-0-1 exited on signal 0 (Unknown signal 0).
> --------------------------------------------------------------------------
> mpirun: clean termination accomplished
>
> I really don't know what's wrong here. I was sure that would work
>
> On Mon, Apr 4, 2011 at 2:43 PM, Samuel K. Gutierrez <samuel_at_[hidden]> wrote:
> Hi,
>
> Try prepending the path to your compiler libraries.
>
> Example (bash-like):
>
> export LD_LIBRARY_PATH=/compiler/prefix/lib:/ompi/prefix/lib:$LD_LIBRARY_PATH
>
> --
> Samuel K. Gutierrez
> Los Alamos National Laboratory
>
>
> On Apr 4, 2011, at 1:33 PM, Nehemiah Dacres wrote:
>
>> altering LD_LIBRARY_PATH alter's the process's path to mpi's libraries, how do i alter its path to compiler libs like libfui.so.1? it needs to find them cause it was compiled by a sun compiler
>>
>> On Mon, Apr 4, 2011 at 10:06 AM, Nehemiah Dacres <dacresni_at_[hidden]> wrote:
>>
>> As Ralph indicated, he'll add the hostname to the error message (but that might be tricky; that error message is coming from rsh/ssh...).
>>
>> In the meantime, you might try (csh style):
>>
>> foreach host (`cat list`)
>> echo $host
>> ls -l /opt/SUNWhpc/HPC8.2.1c/sun/bin/orted
>> end
>>
>>
>> that's what the tentakel line was refering to, or ...
>>
>>
>>
>> On Apr 4, 2011, at 10:24 AM, Nehemiah Dacres wrote:
>>
>> > I have installed it via a symlink on all of the nodes, I can go 'tentakel which mpirun ' and it finds it' I'll check the library paths but isn't there a way to find out which nodes are returning the error?
>>
>> I found it misslinked on a couple nodes. thank you
>>
>> --
>> Nehemiah I. Dacres
>> System Administrator
>> Advanced Technology Group Saint Louis University
>>
>>
>>
>>
>> --
>> Nehemiah I. Dacres
>> System Administrator
>> Advanced Technology Group Saint Louis University
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> --
> Nehemiah I. Dacres
> System Administrator
> Advanced Technology Group Saint Louis University
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users