Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] intel compiler linking issue and issue of environment variable on remote node, with open mpi 1.4.3
From: Tim Prince (n8tm_at_[hidden])
Date: 2011-03-21 08:46:42


On 3/21/2011 5:21 AM, yanyg_at_[hidden] wrote:

> I am trying to compile our codes with open mpi 1.4.3, by intel
> compilers 8.1.
>
> (1) For open mpi 1.4.3 installation on linux beowulf cluster, I use:
>
> ./configure --prefix=/home/yiguang/dmp-setup/openmpi-1.4.3
> CC=icc
> CXX=icpc F77=ifort FC=ifort --enable-static LDFLAGS="-i-static -
> static-libcxa" --with-wrapper-ldflags="-i-static -static-libcxa" 2>&1 |
> tee config.log
>
> and
>
> make all install 2>&1 | tee install.log
>
> The issue is that I am trying to build open mpi 1.4.3 with intel
> compiler libraries statically linked to it, so that when we run
> mpirun/orterun, it does not need to dynamically load any intel
> libraries. But what I got is mpirun always asks for some intel
> library(e.g. libsvml.so) if I do not put intel library path on library
> search path($LD_LIBRARY_PATH). I checked the open mpi user
> archive, it seems only some kind user mentioned to use
> "-i-static"(in my case) or "-static-intel" in ldflags, this is what I did,
> but it seems not working, and I did not get any confirmation whether
> or not this works for anyone else from the user archive. could
> anyone help me on this? thanks!
>

If you are to use such an ancient compiler (apparently a 32-bit one),
you must read the docs which come with it, rather than relying on
comments about a more recent version. libsvml isn't included
automatically at link time by that 32-bit compiler, unless you specify
an SSE option, such as -xW.
It's likely that no one has verified OpenMPI with a compiler of that
vintage. We never used the 32-bit compiler for MPI, and we encountered
run-time library bugs for the ifort x86_64 which weren't fixed until
later versions.

-- 
Tim Prince