Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Error in Binding MPI Process to a socket
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-03-17 15:55:33


What OS version is it?

uname -a

will tell you, if you are on linux.

On Mar 17, 2011, at 1:31 PM, vaibhav dutt wrote:

> Hi,
>
> Thanks for your reply. I tried to execute first a process by using
>
> mpirun -machinefile hostfile.txt --slot-list 0:1 -np 1
>
> but it gives the same as error as mentioned previously.
>
> Then, I created a rankfile with contents"
>
> rank 0=t1.tools.xxx slot=0:0
> rank 1=t1.tools.xxx slot=1:0.
>
> and the used command
>
> mpirun -machinefile hostfile.txt --rankfile my_rankfile.txt -np 2
>
> but ended up getting same error. Is there any patch that I can install in my system to make it
> topology aware?
>
> Thanks
>
>
> On Thu, Mar 17, 2011 at 2:05 PM, Ralph Castain <rhc_at_[hidden]> wrote:
> The error is telling you that your OS doesn't support queries telling us what cores are on which sockets, so we can't perform a "bind to socket" operation. You can probably still "bind to core", so if you know what cores are in which sockets, then you could use the rank_file mapper to assign processes to groups of cores in a socket.
>
> It's just that we can't do it automatically because the OS won't give us the required info.
>
> See "mpirun -h" for more info on slot lists.
>
> On Mar 17, 2011, at 11:26 AM, vaibhav dutt wrote:
>
> > Hi,
> >
> > I am trying to perform an experiment in which I can spawn 2 MPI processes, one on each socket in a 4 core node
> > having 2 dual cores. I used the option "bind to socket" which mpirun for that but I am getting an error like:
> >
> > An attempt was made to bind a process to a specific hardware topology
> > mapping (e.g., binding to a socket) but the operating system does not
> > support such topology-aware actions. Talk to your local system
> > administrator to find out if your system can support topology-aware
> > functionality (e.g., Linux Kernels newer than v2.6.18).
> >
> > Systems that do not support processor topology-aware functionality cannot
> > use "bind to socket" and other related functionality.
> >
> >
> > Can anybody please tell me what is this error about. Is there any other option than "bind to socket"
> > that I can use.
> >
> > Thanks.
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users