Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Building OpenMPI on Windows 7
From: hi (hiralsmaillist_at_[hidden])
Date: 2011-03-16 09:46:54


Hi Shiquing / Damien,

Thanks for the quick reply.

> it's only experimental in 1.4 series. And there is only F77 bingdings on
Windows, no F90 bindings.
Can you please provide steps to build 1.4.3 with experimental f77 bindings
on Windows?

BTW: Do you have any idea on: when next stable release with full fortran
support on Windows would be available?

Thank you.
-Hiral
On Wed, Mar 16, 2011 at 6:59 PM, Shiqing Fan <fan_at_[hidden]> wrote:

> Hi Hiral,
>
> 1.3.4 is quite old, please use the latest version. As Damien noted, the
> full fortran support is in 1.5 series, it's only experimental in 1.4 series.
> And there is only F77 bingdings on Windows, no F90 bindings. Another choice
> is to use the released binary installers to avoid compiling everything by
> yourself.
>
>
> Best Regards,
> Shiqing
>
>
> On 3/16/2011 11:47 AM, hi wrote:
>
> Greetings!!!
>
>
>
> I am trying to build openmpi-1.3.4 and openmpi-1.4.3 on Windows 7 (64-bit
> OS), but getting some difficuty...
>
>
>
> My build environment:
>
> OS : Windows 7 (64-bit)
>
> C/C++ compiler : Visual Studio 2008 and Visual Studio 2010
>
> Fortran compiler: Intel "ifort"
>
>
>
> Approach: followed the "First Approach" described in README.WINDOWS file.
>
>
>
> *1) Using openmpi-1.3.4:***
>
> Observed build time error in version.cc(136). This error is related to
> getting SVN version information as described in
> http://www.open-mpi.org/community/lists/users/2010/01/11860.php. As we are
> using this openmpi-1.3.4 stable version on Linux platform, is there any fix
> to this compile time error?
>
>
>
> *2) Using openmpi-1.4.3:***
>
> Builds properly without F77/F90 support (i.e. i.e. Skipping MPI F77
> interface).
>
> Now to get the "mpif*.exe" for fortran programs, I provided proper
> "ifort" path and enabled "OMPI_WANT_F77_BINDINGS=ON" and/or
> OMPI_WANT_F90_BINDINGS=ON flag; but getting following errors...
>
> * 2.a) "ifort" with OMPI_WANT_F77_BINDINGS=ON gave following errors... *
>
> Check ifort external symbol convention...
>
> Check ifort external symbol convention...single underscore
>
> Check if Fortran 77 compiler supports LOGICAL...
>
> Check if Fortran 77 compiler supports LOGICAL...done
>
> Check size of Fortran 77 LOGICAL...
>
> CMake Error at contrib/platform/win32/CMakeModules/f77_get_sizeof.cmake:76
> (MESSAGE):
>
> Could not determine size of LOGICAL.
>
> Call Stack (most recent call first):
>
> contrib/platform/win32/CMakeModules/f77_check.cmake:82
> (OMPI_F77_GET_SIZEOF)
>
> contrib/platform/win32/CMakeModules/ompi_configure.cmake:1123
> (OMPI_F77_CHECK)
>
> CMakeLists.txt:87 (INCLUDE)
>
> Configuring incomplete, errors occurred!
>
>
>
> * 2.b) "ifort" with OMPI_WANT_F90_BINDINGS=ON gave following errors... *
>
> Skipping MPI F77 interface
>
> CMake Error: File
> C:/openmpi-1.4.3/contrib/platform/win32/ConfigFiles/mpif90-wrapper-data.txt.cmake
> does not exist.
>
> CMake Error at ompi/tools/CMakeLists.txt:93 (CONFIGURE_FILE):
>
> configure_file Problem configuring file
>
> CMake Error: File
> C:/openmpi-1.4.3/contrib/platform/win32/ConfigFiles/mpif90-wrapper-data.txt.cmake
> does not exist.
>
> CMake Error at ompi/tools/CMakeLists.txt:97 (CONFIGURE_FILE):
>
> configure_file Problem configuring file
>
> looking for ccp...
>
> looking for ccp...not found.
>
> looking for ccp...
>
> looking for ccp...not found.
>
> Configuring incomplete, errors occurred!
>
>
>
> * 2.c) "ifort" with OMPI_WANT_F77_BINDINGS=ON and
> OMPI_WANT_F90_BINDINGS=ON gave following errors... *
>
> Check ifort external symbol convention...
>
> Check ifort external symbol convention...single underscore
>
> Check if Fortran 77 compiler supports LOGICAL...
>
> Check if Fortran 77 compiler supports LOGICAL...done
>
> Check size of Fortran 77 LOGICAL...
>
> CMake Error at contrib/platform/win32/CMakeModules/f77_get_sizeof.cmake:76
> (MESSAGE):
>
> Could not determine size of LOGICAL.
>
> Call Stack (most recent call first):
>
> contrib/platform/win32/CMakeModules/f77_check.cmake:82
> (OMPI_F77_GET_SIZEOF)
>
> contrib/platform/win32/CMakeModules/ompi_configure.cmake:1123
> (OMPI_F77_CHECK)
>
> CMakeLists.txt:87 (INCLUDE)
>
> Configuring incomplete, errors occurred!
>
>
>
> Any idea on resolving above errors to get mpif*.exe generated on Windows
> platform using "ifort"?
>
> Please let me know if more information is required.
> Thank you in advance.
>
> -Hiral
>
>
> _______________________________________________
> users mailing listusers_at_[hidden]http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> --
> ---------------------------------------------------------------
> Shiqing Fan
> High Performance Computing Center Stuttgart (HLRS)
> Tel: ++49(0)711-685-87234 Nobelstrasse 19
> Fax: ++49(0)711-685-65832 70569 Stuttgarthttp://www.hlrs.de/organization/people/shiqing-fan/
> email: fan_at_[hidden]
>
>