Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Building OpenMPI on Windows 7
From: Damien (damien_at_[hidden])
Date: 2011-03-16 08:53:25


Hi Hiral,

The 1.4 series doesn't have Fortran support on Windows. You need to use
1.5.

Damien

On 16/03/2011 4:47 AM, hi wrote:
>
> Greetings!!!
>
> I am trying to build openmpi-1.3.4 and openmpi-1.4.3 on Windows 7
> (64-bit OS), but getting some difficuty...
>
> My build environment:
>
> OS : Windows 7 (64-bit)
>
> C/C++ compiler : Visual Studio 2008 and Visual Studio 2010
>
> Fortran compiler: Intel "ifort"
>
> Approach: followed the "First Approach" described in README.WINDOWS file.
>
> *1) Using openmpi-1.3.4:***
>
> Observed build time error in version.cc(136). This error is
> related to getting SVN version information as described in
> http://www.open-mpi.org/community/lists/users/2010/01/11860.php. As we
> are using this openmpi-1.3.4 stable version on Linux platform, is
> there any fix to this compile time error?
>
> *2) Using openmpi-1.4.3:***
>
> Builds properly without F77/F90 support (i.e. i.e. Skipping MPI
> F77 interface).
>
> Now to get the "mpif*.exe" for fortran programs, I provided proper
> "ifort" path and enabled "OMPI_WANT_F77_BINDINGS=ON" and/or
> OMPI_WANT_F90_BINDINGS=ON flag; but getting following errors...
>
> * 2.a) "ifort" with OMPI_WANT_F77_BINDINGS=ON gave following errors... *
>
> Check ifort external symbol convention...
>
> Check ifort external symbol convention...single underscore
>
> Check if Fortran 77 compiler supports LOGICAL...
>
> Check if Fortran 77 compiler supports LOGICAL...done
>
> Check size of Fortran 77 LOGICAL...
>
> CMake Error at
> contrib/platform/win32/CMakeModules/f77_get_sizeof.cmake:76 (MESSAGE):
>
> Could not determine size of LOGICAL.
>
> Call Stack (most recent call first):
>
> contrib/platform/win32/CMakeModules/f77_check.cmake:82
> (OMPI_F77_GET_SIZEOF)
>
> contrib/platform/win32/CMakeModules/ompi_configure.cmake:1123
> (OMPI_F77_CHECK)
>
> CMakeLists.txt:87 (INCLUDE)
>
> Configuring incomplete, errors occurred!
>
> *2.b) "ifort" with OMPI_WANT_F90_BINDINGS=ON gave following errors... *
>
> Skipping MPI F77 interface
>
> CMake Error: File
> C:/openmpi-1.4.3/contrib/platform/win32/ConfigFiles/mpif90-wrapper-data.txt.cmake
> does not exist.
>
> CMake Error at ompi/tools/CMakeLists.txt:93 (CONFIGURE_FILE):
>
> configure_file Problem configuring file
>
> CMake Error: File
> C:/openmpi-1.4.3/contrib/platform/win32/ConfigFiles/mpif90-wrapper-data.txt.cmake
> does not exist.
>
> CMake Error at ompi/tools/CMakeLists.txt:97 (CONFIGURE_FILE):
>
> configure_file Problem configuring file
>
> looking for ccp...
>
> looking for ccp...not found.
>
> looking for ccp...
>
> looking for ccp...not found.
>
> Configuring incomplete, errors occurred!
>
> *2.c) "ifort" with OMPI_WANT_F77_BINDINGS=ON and
> OMPI_WANT_F90_BINDINGS=ON gave following errors... *
>
> Check ifort external symbol convention...
>
> Check ifort external symbol convention...single underscore
>
> Check if Fortran 77 compiler supports LOGICAL...
>
> Check if Fortran 77 compiler supports LOGICAL...done
>
> Check size of Fortran 77 LOGICAL...
>
> CMake Error at
> contrib/platform/win32/CMakeModules/f77_get_sizeof.cmake:76 (MESSAGE):
>
> Could not determine size of LOGICAL.
>
> Call Stack (most recent call first):
>
> contrib/platform/win32/CMakeModules/f77_check.cmake:82
> (OMPI_F77_GET_SIZEOF)
>
> contrib/platform/win32/CMakeModules/ompi_configure.cmake:1123
> (OMPI_F77_CHECK)
>
> CMakeLists.txt:87 (INCLUDE)
>
> Configuring incomplete, errors occurred!
>
> Any idea on resolving above errors to get mpif*.exe generated on
> Windows platform using "ifort"?
>
> Please let me know if more information is required.
> Thank you in advance.
>
> -Hiral
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users