Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem running openmpi-1.4.3
From: Gus Correa (gus_at_[hidden])
Date: 2011-03-08 20:30:10


Ralph Castain wrote:
> You need to set your LD_LIBRARY_PATH to point to where you installed openmpi.
>
>
> On Mar 8, 2011, at 5:47 PM, Amos Leffler wrote:
>
>> Hi,
>> I am trying to get openmpi-1.4.3 to run but am having trouble.
>> It is run using SUSE-11.3 with Intel XE-2011 Composer C and Fortran
>> compilers. The compilers installed without problems. The openmpi
>> file was downloaded and unzipped and untarred. The ./configure
>> command was run and it was found to be necessary to set CC=gcc and
>> CXX=g++. The fortran F77 and F90 were set to ifort. The --prefix was
>> set to /usr. The program appeared to compile properly but none of the
>> examples given would not compile. The error messages are shown below:
>>
>> linux-q2bz:/home/amosleffler/Downloads/openmpi-1.4.3/examples # mpicc
>> hello_c.c =o hello_c
>> mpicc: error while loading shared libraries: libopen-pal.so.0: cannot
>> open shared object file: No such file or directory
>> linux-q2bz:/home/amosleffler/Downloads/openmpi-1.4.3/examples # mpiCC
>> hello_cxx.cc -o hello_cxx
>> mpiCC: error while loading shared libraries: libopen-pal.so.0: cannot
>> open shared object file: No such file or directory
>> linux-q2bz:/home/amosleffler/Downloads/openmpi-1.4.3/examples # mpif77
>> hello_f77.f -o hello_f77
>> mpif77: error while loading shared libraries: libopen-pal.so.0: cannot
>> open shared object file: No such file or directory
>> linux-q2bz:/home/amosleffler/Downloads/openmpi-1.4.3/examples # mpif90
>> hello_f90.f90 -o hello_f90
>> mpif90: error while loading shared libraries: libopen-pal.so.0: cannot
>> open shared object file: No such file or directory
>> linux-q2bz:/home/amosleffler/Downloads/openmpi-1.4.3/examples
>>
>> It is evident that the same error is present in all attempts to
>> compile but I don't know why it is absent. Any help would be much
>> appreciated.
>>
>>
>> Amos Leffler
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

These FAQ detail what David and Ralph said:

http://www.open-mpi.org/faq/?category=running#run-prereqs
http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path

You can prepend or append (don't overwrite)
the OpenMPI library directory to your current LD_LIBRARY_PATH,
so as to keep he Intel ifort library path there also.

My two cents,
Gus Correa