Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Error in executing NAS Benchmarks
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-03-04 15:58:02


It looks like your PATH is not set properly on the remote nodes to find the Open MPI installation. Check the FAQ for some details on this.

On Mar 4, 2011, at 2:26 PM, vaibhav dutt wrote:

> Hi,
>
>
> I am trying to execute NAS benchmark across 2 Nodes, each having 4 cores.
> The execution works fine on a single node, but when I try to execute the benchmark across 2 Nodes, I
> get an error like:
>
> mpiexec -machinefile hostfile.txt -n 8 ./ep.A.8
> bash: orted: command not found
> ------------------------------
> --------------------------------------------
> A daemon (pid 22973) died unexpectedly with status 127 while attempting
> to launch so we are aborting.
>
> There may be more information reported by the environment (see above).
>
> This may be because the daemon was unable to find all the needed shared
> libraries on the remote node. You may set your LD_LIBRARY_PATH to have the
> location of the shared libraries on the remote nodes and this will
> automatically be forwarded to the remote nodes.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpiexec noticed that the job aborted, but has no info as to the process
> that caused that situation.
> --------------------------------------------------------------------------
> mpiexec: clean termination accomplished
>
>
> Can anybody please suggest the reason for this.
>
> Thanks,
> Vaibhav
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/