Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Basic question on portability
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-03-01 12:56:26


Yes, you will have problems.

We did not formally introduce ABI compatibility until version 1.3.2. Meaning: your application compiled with 1.3.2 will successfully link/run against any 1.3.x version >= 1.3.2, and against any 1.4.x version.

v1.5 broke ABI with the v1.3/v1.4 series, but it will also be stable for the duration of the v1.5/v1.6 series.

We have no definite plans yet for v1.7, but it is likely that the ABI story will be the same there, too -- break from v1.5/v1.6 and stable for v1.7/v1.8.

On Mar 1, 2011, at 11:25 AM, Blosch, Edwin L wrote:

> If I compile against OpenMPI 1.2.8, shared linkage, on one system, then move the executable to another system with OpenMPI 1.4.x or 1.5.x, will I have any problems running the executable?
>
> Thanks
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/