Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] libmpi.so.0 not found during gdb debugging
From: swagat mishra (swagatmishra2007_at_[hidden])
Date: 2011-02-11 09:28:57


yes setting LD_LIBRARY_PATH solved the problem
thanks for the help
On Fri, Feb 11, 2011 at 7:14 PM, Prentice Bisbal <prentice_at_[hidden]> wrote:

> swagat mishra wrote:
> > hello everyone,
> > i have a network of systems connected over lan with each computer
> > running ubuntu. openmpi 1.4.x is installed on 1 machine and the
> > installation is mounted on other nodes through Networking File
> > System(NFS). the source program and compiled file(a.out) are present in
> > the mounted directory
> > i run my programs by the following command:
> > /opt/project/bin/mpirun -np 4 --prefix /opt/project/ --hostfile
> > hostfile a.out
> > i have not set LD_LIBRARY_PATH but as i use --prefix mpirun works
> > successfully
> >
> > however as per the open mpi debugging faq:
> > http://www.open-mpi.org/faq/?category=debugging
> > when i run
> > /opt/project/bin/mpirun -np 4 --prefix /opt/project/ --hostfile
> > hostfile -x DISPLAY=10.0.0.1:0.0 xterm -e gdb a.out
> >
> > 4 xterm windows are opened with gdb running as expected. however when i
> > give the command start to gdb in the windows corresponding to remote
> > nodes, i get the error:
> > libmpi.so.0 not found: no such file/directory
> >
> > as mentioned other mpi jobs run fine with mpirun
> >
> > when i execute
> > /opt/project/bin/mpirun -np 4 --prefix /opt/project/ -x
> > DISPLAY=10.0.0.1:0.0 xterm -e gdb a.out ,the debugging continues
> succesfully
> >
> > please help
> >
>
> You need to set LD_LIBRARY_PATH to include the path to the OpenMPI
> libraries. The --prefix option works for OpenMPI only; it has no effect
> on other programs. You also need to make sure that the LD_LIBRARY_PATH
> variable is correctly passed along to the other OpenMPI programs. For
> processes on other hosts, this is usually done by editing your shell's
> rc file for non-interactive logins (.bash_profile for bash).
>
> --
> Prentice
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>