Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI_ERR_IN_STATUS from MPI_Bcast?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-02-10 08:31:14


Nifty! Yes, I agree that that's a poor error message. It's probably (unfortunately) being propagated up from the underlying point-to-point system, where an ERR_IN_STATUS would actually make sense.

I'll file a ticket about this. Thanks for the heads up.

On Feb 9, 2011, at 4:49 PM, Jeremiah Willcock wrote:

> On Wed, 9 Feb 2011, Jeremiah Willcock wrote:
>
>> I get the following Open MPI error from 1.4.1:
>>
>> *** An error occurred in MPI_Bcast
>> *** on communicator MPI COMMUNICATOR 3 SPLIT FROM 0
>> *** MPI_ERR_IN_STATUS: error code in status
>> *** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
>>
>> (hostname and port removed from each line). There is no MPI_Status returned by MPI_Bcast, so I don't know what the error is? Is this something that people have seen before?
>
> For the record, this appears to be caused by specifying inconsistent data sizes on the different ranks in the broadcast operation. The error message could still be improved, though.
>
> -- Jeremiah Willcock
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/