Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Default hostfile not being used by mpirun
From: ETHAN DENEAULT (EDENEAULT_at_[hidden])
Date: 2011-02-05 17:14:44


Barnet,

This isn't the most straightforward solution, but as a workaround, create a bash script and run that script through npRmpi? Something like:

!#/bin/bash

openmpi -np 15 -hostfile /path/to/hostfile $1

Cheers,
Ethan

--
Dr. Ethan Deneault
Assistant Professor of Physics
The University of Tampa
401 W Kennedy Blvd
Tampa, FL 33606
(813) 732-3718
Barnet Wagman <bw_at_[hidden]> wrote:
There have been many postings about openmpi-default-hostfile on the
list, but I haven't found one that answers my question, so I hope you
won't mind one more.
When I use mpirun, openmpi-default-hostfile does not appear to get used.
I've added three lines to the default host file:
    node0 slots=3
    node1 slots=4
    node2 slots=4
'node0' is the local (master) host.
If I explicitly list the hostfile in the mpirun command, everything
works correctly.  E.g.
    mpirun -np 15 -hostfile /full/path/to/openmpi-default-hostfile hello_c
works correctly - hello_c gets run using all three nodes.
However, if I don't specify the hostfile, only the local node, node0, is
used. E.g.
    mpirun -np 15 hello_c
creates all 15 processes on node0.  I was under the impression that all
machines listed in openmpi-default-hostfile should get used by default. 
Is that correct?
Unfortunately I can't use the hostfile command line option.  I'm going
to be using a mpi app (npRmpi) that doesn't let me pass params to
mpirun. So I need all my nodes used by default.
Configuration details:
    openmpi 1.4.3, built from source.
    OS: Debian lenny (but the Debian openmpi package is NOT installed).
    Installation dir: /home/omu/openmpi
    The default host file has pathname
    /home/omu/openmpi/etc/openmpi-default-hostfile
    I've set two envirnmental variables to support open mpi:
        PATH=/home/omu/openmpi/bin:...
        LD_LIBRARY_PATH=/home/omu/openmpi/lib:...
Are there any other environmental variables that need to be set?
I'd appreciate any suggestions about this.
thanks,
Barnet Wagman