Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] heterogenous cluster
From: jody (jody.xha_at_[hidden])
Date: 2011-02-02 02:46:58


Thanks for your reply.

If i try your suggestion, every process fails with the following message:

*** The MPI_Init() function was called before MPI_INIT was invoked.
*** This is disallowed by the MPI standard.
*** Your MPI job will now abort.
[aim-triops:15460] Abort before MPI_INIT completed successfully; not
able to guarantee that all other processes were killed!

I think this is caused by the fact that on the 64Bit machine Open MPI
is also built as a 64 bit application.
How can i force OpenMPI to be built as a 32Bit application on a 64Bit machine?

Thank You
Jody

On Tue, Feb 1, 2011 at 9:00 PM, David Mathog <mathog_at_[hidden]> wrote:
>
>> I have sofar used a homogenous 32-bit cluster.
>> Now i have added a new machine which is 64 bit
>>
>> This means i have to reconfigure open MPI with
> `--enable-heterogeneous`, right?
>
> Not necessarily.  If you don't need the 64bit capabilities you could run
> 32 bit binaries along with a 32 bit version of OpenMPI.  At least that
> approach has worked so far for me.
>
> Regards,
>
> David Mathog
> mathog_at_[hidden]
> Manager, Sequence Analysis Facility, Biology Division, Caltech
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>