Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] bash: orted: ... / Kedar Soparkar
From: Kedar Soparkar (kedarsoparkar_at_[hidden])
Date: 2011-01-24 14:01:58


The exact contents of the environment variables as reported by 'env' are:

PATH=/usr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/lib/openmpi/bin:/home/mpiuser/bin
LD_LIBRARY_PATH=/usr/lib/openmpi/lib

Am I missing some other variables?

-Kedar

> ---------- Forwarded message ----------
> From: Reuti <reuti_at_[hidden]>
> To: Open MPI Users <users_at_[hidden]>
> Date: Mon, 24 Jan 2011 13:48:51 +0100
> Subject: Re: [OMPI users] bash: orted: command not found despite env vars being set
> Am 24.01.2011 um 11:47 schrieb Kedar Soparkar:
>
>> I'm trying to setup a small cluster of 2 nodes.
>>
>> Both nodes are running Fedora 11 Kernel 2.6.29.4, have the same user
>> mpiuser with the same password. Both of them have their env vars set
>> as follows in /etc/profile itself:
>
> This is syntax for which type of shell?
>
>> PATH                                usr/lib/openmpi/bin
>> LD_LIBRARY_PATH           usr/lib/openmpi/lib
>
> The leading slash is missing in case you want to specify absolute paths. And any set path should be retained and not be replaced:
>
> export PATH=/usr/lib/openmpi/bin${PATH:+:$PATH}
> export LD_LIBRARY_PATH=/usr/lib/openmpi/lib${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
>
> -- Reuti
>
>
>> Currently, mpirun executes successfully on either node individually.
>> However, when trying to run over the network, I get:
>>
>> [mpiuser_at_c-199 ~]$ mpirun -np 3 --hostfile .mpi_hostfile ./a.out
>> bash: orted: command not found
>> --------------------------------------------------------------------------
>> A daemon (pid 12639) died unexpectedly with status 127 while attempting
>> to launch so we are aborting.
>>
>> There may be more information reported by the environment (see above).
>>
>> This may be because the daemon was unable to find all the needed shared
>> libraries on the remote node. You may set your LD_LIBRARY_PATH to have the
>> location of the shared libraries on the remote nodes and this will
>> automatically be forwarded to the remote nodes.
>> --------------------------------------------------------------------------
>> --------------------------------------------------------------------------
>> mpirun noticed that the job aborted, but has no info as to the process
>> that caused that situation.
>> --------------------------------------------------------------------------
>> mpirun: clean termination accomplished
>>
>> What fixes should I try to get the cluster to work?
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users