Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] parallel with parallel of wie2k code
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-01-14 09:31:35


These don't look like error messages from Open MPI; it's quite possible that you accidentally mixed multiple MPI implementations when compiling and/or running your application.

On Jan 14, 2011, at 6:35 AM, lagoun brahim wrote:

> dear user's
> i have compiled the wien2k code with openmpi 1.4 (ifort11.1+icc2011+icpc+mkl libraries10.2) in smp machines (quad) with open suse 10.3 64bits
> but when i run the parallel version i have the following error message
> run_lapw -p -cc 0.01
> LAPW0 END
> Fatal error in MPI_Comm_size: Invalid communicator, error stack:
> MPI_Comm_size(111): MPI_Comm_size(comm=0x5b, size=0x8fe10c) failed
> MPI_Comm_size(69).: Invalid communicator
> Fatal error in MPI_Comm_size: Invalid communicator, error stack:
> MPI_Comm_size(111): MPI_Comm_size(comm=0x5b, size=0x8fe10c) failed
> MPI_Comm_size(69).: Invalid communicator
> Fatal error in MPI_Comm_size: Invalid communicator, error stack:
> MPI_Comm_size(111): MPI_Comm_size(comm=0x5b, size=0x8fe10c) failed
> MPI_Comm_size(69).: Invalid communicator
> Fatal error in MPI_Comm_size: Invalid communicator, error stack:
> MPI_Comm_size(111): MPI_Comm_size(comm=0x5b, size=0x8fe10c) failed
> MPI_Comm_size(69).: Invalid communicator
> cat: No match.
>
> > stop error
> i don't now where is the probleme
> i need your help please
> and thanks in advance
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/